Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Just installed Debian 5.0.3 from one single 700MB CD and all have is a command line when I start Debian. Is there a way to launch a GUI interface from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    10

    How to get GUI interface in Debian 5.0.3 from command line?


    Just installed Debian 5.0.3 from one single 700MB CD and all have is a command line when I start Debian. Is there a way to launch a GUI interface from the command line? Thanks

  2. #2
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    Not having done that for a while, as far as I remember either:
    Code:
    startx
    or
    Code:
    init runlevel 5
    should work. If you know which gui you have you could do:
    start LXDE, or start XFCE, start gnome, etc.
    Registered Linux User #420832

  3. #3
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,042
    I use startx ... you need to add an entry to ~/.xinitrc first ... from my Ach setup
    Code:
    ### Uncomment required Window Manager or Desktop Environment
    
    # kdemod3
    #exec /opt/kde/bin/startkde
    
    # lxde
    #exec startlxde
    
    # fluxbox
    #exec fluxbox
    
    # xfce4
    #exec startxfce4
    
    # uncomment to just run konqueror
    #exec /opt/kde/bin/konqueror
    
    # IceWM
    exec icewm-session
    Hope that helps

  4. #4
    Just Joined!
    Join Date
    Oct 2009
    Posts
    10
    thank you guys for reply,

    when I type startx I get in the end
    Fatal server error:
    no screens found
    giving up.
    xinit: COnnection reset by peer (errno 104): unable to connect to X server
    xinit: No such process (errno 3): Server error.

    when I anything like exec /opt/kde/bin/startkde
    it says no such file or directory, or something like that

    Also after Debian loaded up and start asking me for login and password the screen blinks few times and gives me a message:
    Failed to start X server (your graphical interface). It is likely that it is not setup correctly. Would you like to view the X server output to diagnose the problem? Yes No

    I press Yes, then

    Before reporting problems, check to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct 28 21:02:03 2009
    (==) Using config file: "/etc/X11/xorg.conf"
    (II) Module "i2c" already built-in
    (II) Module "ddc" already built-in
    (EE) RADEONHD(0): rhdAtomLvdsDDC: unknow record type: 90
    (EE) RADEONHD(0): Output PANEL enabled but has no modes
    (EE) RADEONHD(0): RandR: No valid modes. Disabled.
    (EE) RADEONHD(0): rhdAtomLvdsDDC: unknow record type: 90
    (EE) RADEONHD(0): No valid modes found
    (EE) Screen(s) found, but none have usable configuration.

    Fatal error:
    no screens found

    From all this I understand that my video driver is not setup properly and at least I must go and look up about X

    Or maybe I'm wrong?

    I have laptop with ATI Radeon 3400 video card which is picked up by Ubuntu without problems.

    I'll go and continue google, meanwhile you guys could give me some more advice?

  5. #5
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,184
    Your diagnosis is probably correct. You could try running xorg -configure as root. This usually manages to create a workable xorg.conf file for you.

    If you are dual-booting with Ubuntu, a quick and dirty way is to copy the Ubuntu version of xorg.conf to your Debian /etc/X11 directory.
    "I'm just a little old lady; don't try to dazzle me with jargon!"

  6. #6
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    You could try running xorg -configure as root.
    Another option (again as root) is
    Code:
    sudo dpkg-reconfigure -phigh xserver-xorg
    Do you know what desktop environment you installed? GNOME, KDE, XFCE, etc?

  7. #7
    Just Joined!
    Join Date
    Oct 2009
    Posts
    10
    When I was logged-in in Debian myusername@computername I typed "xorg -configure" and it told me that the "command not found". I probably don't know how to do it through "root" as you say. How do I get to root?

    I tried to type also in myusername@computername "su xorg -configure" and it gave me "unknown id: xorg"

    The Debian I installed and currently in is 5.0.3, the first 700MB ISO image from the Debian website. So I don't know which desktop environment is installed. Could you help me how to find out?

    WHen I typed in "sudo dpkg-reconfigure -phigh xserver-xorg" it asked me for password [sudo] password for myusername. I typed the password I usually log in with, but it didn't work. Then I realized maybe I don't have a password for root at all and I put again "sudo dpkg-reconfigure -phigh xserver-xorg", when asked for password I just hit "Enter" and then it didn't give me any message, just the line appeared in the bottom myusername@computername _

    Well, I rebooted Debian to see if this changed anything, but it didn't. Still the same blue screen asking me about X server and I still can't load any GUI interface what a hopeless newbie am I? )))))

    Okay, I booted into Ubuntu which is installed on my other partition with purpose to try a quick and dirty way to copy the Ubuntu version of xorg.conf to my Debian /etc/X11 directory. But when I tried to copy this file using File Browser guess what happened? "Error while copying xorg.conf permission denied. It actually does not allow me to do any changes to files installed on Debian partition. How do I grant access?

  8. #8
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Sorry, my fault on the sudo. Debian doesn't set up sudo by default.

    You should have set up a root password during install.
    To login to the shell as root do
    Code:
    su -
    then enter the password. You can also run just one command with
    Code:
    su -c 'command goes here'
    The normal first CD of Debian only contains the GNOME environent, I believe. During install there would have been an option to install a Desktop Environment, which would default to GNOME. It sounds like you did not install a GUI.

  9. #9
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Forgot, what is the output of
    Code:
    dpkg -l | grep xorg
    That's a lower case L, not a 1.

  10. #10
    Just Joined!
    Join Date
    Oct 2009
    Posts
    10
    thanks for this hint su - to log in as root. successfully logged in, but when typed in root xorg -configure gave me -su: xorg: command not found

    the command sudo dpkg-reconfigure -phigh xserver-xorg did well and gave me message in the end overwriting possibly-customised configuration file; backup in /etc/X11/xorg.conf.20091029....

    this command also worked dpkg -l | grep xorg
    message about X server something VESA display driver gave me in the end

    then I rebooted Debian, same problem

    as long as I remember I installed Desktop Environment. How can I check?

    Could you give me info again to try to load any of GUI interfaces?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •