Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
I am trying to connect to my Fedora box in VMWare using Putty. I get a network timeout error. I am trying to connect over port 22 to start with. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    33

    putty - network timeout error


    I am trying to connect to my Fedora box in VMWare using Putty. I get a network timeout error. I am trying to connect over port 22 to start with. Eventually, I need to connect to port 3306 for mysql. I am not a day 1 newbie with Linux as I can move around in it, but my knowledge is limited. So, I am probably missing something basic. I have googled a few spots but all of the putty references are specific to their situations. Where should I start?

    Thanks for your help and patience in advance.

  2. #2
    Just Joined!
    Join Date
    Dec 2009
    Posts
    33
    I will add this. My network connection in Fedora is fiesty. I will start up Fedora and have a network connection. The next time I start it up I won't have the connection. I am using VMWare 2.0. I have the NIC set to bridged. Also, I turned the firewall off since this is an internal system only.

  3. #3
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    You have ssh set up correctly on the Fedora box? Try connecting from Fedoa with the command:

    Code:
    ssh localhost
    Linux User #453176

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2009
    Posts
    33
    ssh: connect to host localhost port 22: connection refused

    I will note that I do not have an internet connection again for some reason. The red x is over the network symbol at the top again. If that is not related, I can take one issue at a time focusing on the ssh and putty this time.

  6. #5
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    It looks as if you haven't installed a SSH server on your Fedora installation. If this is the case then you will need to do this with your package manager first
    Linux User #453176

  7. #6
    Just Joined!
    Join Date
    Dec 2009
    Posts
    33
    I ran this command in the terminal

    yum install openssh-server

    This is what I saw:

    Package openssh-server-5.1p1-3.fc10.i386 already installed and latest version
    Nothing to do

    Was that the ssh server I was supposed to install?

  8. #7
    Just Joined!
    Join Date
    Dec 2009
    Posts
    33
    So, from the last post, I already have the ssh server installed unless I am misunderstanding something.

    For the moment, I figured out my internet connection. I have the internet. Now, I get a connection refused when I try to putty into the box on port 22. I found this when googling:

    Connection refused means that the server sent an RST packet, which it can only do if it's up and has a TCP/IP stack.

    I even tried to enter the ip I was using putty from and put it into the 'ListenAddress" line in the sshd_config file. I restarted sshd. That did not seem to help either. I can ping my box from a different pc also.

    I will also note that I turned my firewall back on in order to get my internet connection. I do not know if the firewall needs to be on in order to get the internet in Linux, but it works for now. I allowed just about everything in the firewall. This may be what is now preventing ssh although it may also be what is giving me my internet. I will wait for the experts now...

  9. #8
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    Yes, that means ssh server is installed.

    Before testing if you can connect via putty try connecting from the computer the ssh server is running on. Then when that is working you know the ssh server is at least running. As I said before you can do this from Fedora with the command:

    Code:
    ssh localhost
    If that doesn't work check if sshd is running (as root):

    Code:
    /sbin/service sshd status
    Linux User #453176

  10. #9
    Just Joined!
    Join Date
    Dec 2009
    Posts
    33
    after running

    'ssh localhost'

    I get 'ssh: connect to host localhost port 22: connection refused'

    After running

    'service sshd status'

    I get 'openssh-daemon is stopped'

    When I look in the services list also, I see that sshd is enabled but stopped. It says that it will awaken when needed ( paraphrasing ).

  11. #10
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    Well that's probably your problem then. Turn on sshd with:

    Code:
    /sbin/service sshd start
    Then check it's running with another:

    Code:
    /sbin/service sshd status
    Linux User #453176

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •