Find the answer to your Linux question:
Results 1 to 8 of 8
I mounted hdb1 at /mnt/Win and hdb5 at /mnt/win98 and work fine. the ploblems its when i try to unpack a tar.gz file like xine-libs, it work at my hda ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2003
    Posts
    5

    permission device


    I mounted hdb1 at /mnt/Win and hdb5 at /mnt/win98 and work fine. the ploblems its when i try to unpack a tar.gz file like xine-libs, it work at my hda = / usr/src but when i try to unpack the file at /mnt/win98/l/ make errors like " xine-lib-1beta cannont change the owner to uid 1001, gid 1001 " not permission to operation

    tar out error.
    my /etc/fstab file

    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/hda3 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
    /dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
    /dev/hdb1 /mnt/Win vfat rw 0 0
    /dev/hdb5 /mnt/win98 vfat rw 0 0

    need to know how can fix it , and what i should to do . thz.


  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Since the FAT filesystem has no support for file ownership, it's only natural that you can't change the owner on a file that is on a FAT file system. Might I suggest first untarring the archive to your Linux partition and then moving the whole tree to your Windows partition?
    Although, why would you want to have these things on a Windows partition at all?

  3. #3
    Just Joined!
    Join Date
    May 2003
    Posts
    5
    cause if i have not enought space in my Hda=fijujitsu 3500mgs would use my other vfat hdb =wester digital 20gs
    can i use vfat hdb to install some stuffs like xine for linux or i need ext3 filesystem?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    A UNIX filesystem would indeed be to prefer. What user are you when you try to untar it? (ie. are you root or a normal user?)

  6. #5
    Just Joined!
    Join Date
    May 2003
    Posts
    5
    root

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Try as a normal user instead. That way, tar knows that it cannot change the ownership of files anyway.

  8. #7
    Just Joined!
    Join Date
    May 2003
    Posts
    5
    i try adding this line at my fstab file conf /etc/fstab

    vfat users,quiet,rw 0 0 and its work . its ok now

  9. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Oh! I thought there would be such an option for vfat, but I had never seen it until now. Thanks for informing me!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •