Find the answer to your Linux question:
Results 1 to 4 of 4
I'm running Linux on an Intel Core 2 Duo processor. When I apply power to my computer, it boots into one core but appears to leave the other one idle. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2010
    Posts
    1

    Missing CPU Core on Boot


    I'm running Linux on an Intel Core 2 Duo processor. When I apply power to my computer, it boots into one core but appears to leave the other one idle. On the screen, it prints:

    ....
    SMP: Allowing 2 CPUs, 1 hotplug CPUs
    .....

    I can confirm that only 1 CPU is active by logging in and examining /proc/interrupts and /proc/cpuinfo. After issuing a "reboot" command, the screen shows:

    ...
    SMP: Allowing 2 CPUs, 0 hotplug CPUs
    ...

    So, when I do a cold boot, I one get 1 CPU. When I do a warm boot, I get both CPUs. This is a problem for me because I'm running Linux on an embedded board and I need both CPUs to be running.

    I've played around with BIOS settings, the boot string, kernel configuration, and CPU hot plugging. I can't seem to find a way to get both processors running without booting the system twice.

    I thought that the CPU hot plugging path showed some promise but I can't seem to get that feature working on my system. The first issue is that the Linux documentation doesn't seem to match with what I'm seeing. It states that you should be able to go into /sys/devices/system/cpu/cpuX/ and write a zero or a one to the file labeled 'online' to disable it or enable it. When I go to /sys/devices/system/cpu I only see a directory for cpu0. There isn't a directory for cpu1.

    After a reboot, I do see two directories int /sys/devices/system/cpu (cpu0 and cpu1). At this point, it won't let me 'offline' the second processor. The echo command gives me an error. (By the Way: the 'online' file in each cpuX directory has read only permissions.) This error occurs after I've changed the permissions on the file to read/write.

    I confirmed that the following parameters are set in my .config file: CONFIG_HOTPLUG, CONFIG_HOTPLUG_CPU, CONFIG_SMP, CONFIG_SUSPEND_SMP

    I've done searches on google until my eyes popped out and can't find much information. I see others have had similar problems but they all seem to link back to ACPI in BIOS. I've already played with all of those settings and i didn't see any effect. One reason I don't think it's a BIOS problem is because a warm boot (reboot) seems to 'fix' it.

    I've tried different kernels, different distributions, and different computers. I see similar behavior in all configurations. I feel like I'm missing something fundamental.

    Any help or ideas would be greatly appreciated!

    Thanks.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,509
    You should probably direct this question to the board vendor. There are a lot of reasons why this is happening, but not ones that anybody who isn't intimately familiar with the board and your linux distribution would know about.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jun 2010
    Posts
    15
    Hi, Have you fixed this problem ? I have the similar problem with you ....

  4. #4
    Just Joined!
    Join Date
    Jul 2010
    Posts
    11
    Quote Originally Posted by ertl View Post
    I'm running Linux on an Intel Core 2 Duo processor. When I apply power to my computer, it boots into one core but appears to leave the other one idle. On the screen, it prints:

    ....
    SMP: Allowing 2 CPUs, 1 hotplug CPUs
    .....

    I can confirm that only 1 CPU is active by logging in and examining /proc/interrupts and /proc/cpuinfo. After issuing a "reboot" command, the screen shows:

    ...
    SMP: Allowing 2 CPUs, 0 hotplug CPUs
    ...

    So, when I do a cold boot, I one get 1 CPU. When I do a warm boot, I get both CPUs. This is a problem for me because I'm running Linux on an embedded board and I need both CPUs to be running.

    I've played around with BIOS settings, the boot string, kernel configuration, and CPU hot plugging. I can't seem to find a way to get both processors running without booting the system twice.

    I thought that the CPU hot plugging path showed some promise but I can't seem to get that feature working on my system. The first issue is that the Linux documentation doesn't seem to match with what I'm seeing. It states that you should be able to go into /sys/devices/system/cpu/cpuX/ and write a zero or a one to the file labeled 'online' to disable it or enable it. When I go to /sys/devices/system/cpu I only see a directory for cpu0. There isn't a directory for cpu1.

    After a reboot, I do see two directories int /sys/devices/system/cpu (cpu0 and cpu1). At this point, it won't let me 'offline' the second processor. The echo command gives me an error. (By the Way: the 'online' file in each cpuX directory has read only permissions.) This error occurs after I've changed the permissions on the file to read/write.

    I confirmed that the following parameters are set in my .config file: CONFIG_HOTPLUG, CONFIG_HOTPLUG_CPU, CONFIG_SMP, CONFIG_SUSPEND_SMP

    I've done searches on google until my eyes popped out and can't find much information. I see others have had similar problems but they all seem to link back to ACPI in BIOS. I've already played with all of those settings and i didn't see any effect. One reason I don't think it's a BIOS problem is because a warm boot (reboot) seems to 'fix' it.

    I've tried different kernels, different distributions, and different computers. I see similar behavior in all configurations. I feel like I'm missing something fundamental.

    Any help or ideas would be greatly appreciated!

    Thanks.

    Can you try to boot with kernel /boot/vmlinuz-2.6.13-Ora10g root=/dev/sda1 ro maxcpus=(insert cpu core number here).

    This method is to limit the cpu core and is not meant to be used in this manner, but hey, if it works, it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •