Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Hey there, I've been messing around to try and play runescape (Java based) on my laptop. I run Lucid Lynx (in dualboot with vista) and have Java installed. Now I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2010
    Posts
    20

    Runescape grey screen


    Hey there,

    I've been messing around to try and play runescape (Java based) on my laptop. I run Lucid Lynx (in dualboot with vista) and have Java installed. Now I'm trying to get Runescape to work so I have even more reason to ban Vista completely.

    So I installed Java, and tried in firefox (3.6.6). It loads the log in, I log in, but then I get a grey screen with "applet started" in the status bar but nothing more.

    When that didn't work I did some googling and tried it with SeaMonkey(2.0.4) - same result. Would another browser help or is there something else wrong?

  2. #2
    Linux User twoHats's Avatar
    Join Date
    Jan 2005
    Location
    NH, USA
    Posts
    280
    Hi - not familiar with runescape, but you might try some of the browser tools such as error console, and page source and troubleshooting info...
    - Clouds don't crash - Bertrand Meyer

    registered Linux user 393557

    finally - hw to brag about - but next year it will look pitifully quaint:
    Athlon64 X2 3800 - 1G PC3200 - 250G SATA - ati radeon x300
    circa 2006

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    8
    Most likely you have the knock-off version of Java, which is usually pre-installed by Ubuntu. Crank open your favorite package manager (I use synaptic) and do a search on 'sun'; to get the jre package. If you open a terminal, type java -version to see what your system thinks is java.

    wayward4now@iam:~$ java -version
    java version "1.6.0_20"
    Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
    Java HotSpot(TM) Client VM (build 16.3-b01, mixed mode, sharing)
    wayward4now@iam:~$

    You should see something like this. It's a common problem.

  4. #4
    Just Joined!
    Join Date
    Dec 2007
    Posts
    22
    Getting a complete and correct installation of Java was difficult for me until I saw post # 14 here: (This crazy forum won't allow me to post the URL) Try "ubuntuforums.org/showthread.php?t=1215746&page=2" with an http in fron of it.

    or You can get there by googling "easylinuxtipsproject/java", then open the first link provided about Oracle Sun Java.

    Works like a charm now.

  5. #5
    Just Joined!
    Join Date
    Jun 2010
    Posts
    20
    I did a complete Java install, installing the self-extracting package from Java.com. If that's wrong then I don't know where to get the "right" java.

  6. #6
    Just Joined!
    Join Date
    Jun 2006
    Posts
    8
    Quote Originally Posted by CaffeinatedCthulhu View Post
    I did a complete Java install, installing the self-extracting package from Java.com. If that's wrong then I don't know where to get the "right" java.
    Whoops! That run package plays merry hell with most distro's if you're not up to configuring all the links to enable it. It's a twisted ordeal. It's best to just use the sun-java .deb file (jre or both jre / jdk by installing the sun-jdk package) using your package manager. That will install all the dependencies and configure the links needed to make it run. Or, you can do it by hand and suffer the tortures if it fails. Make it easy on yourself! It always works and I run some pretty intensive java apps. I haven't hand installed java since I switched to Ubuntu and have never looked back. Ric

  7. #7
    Just Joined!
    Join Date
    Jun 2010
    Posts
    20
    I don't see the sun-jdk package in the list?

  8. #8
    Just Joined!
    Join Date
    Dec 2007
    Posts
    22
    Have you looked at the instructions found by googling "easylinuxtipsproject/jav"?
    If you open the very first option you will see a very detailed set of instructions to install java for Ubuntu. The jdk and ice tea plugin didn't work for me , but the instructions for jre did.

    I agree it shouldnt' be so hard, but this does work.

  9. #9
    Just Joined!
    Join Date
    Jun 2006
    Posts
    8
    look for sun-java6-jdk or just sudo apt-get sun-java6-jdk
    ...that should get you everything you could possibly need. As I mentioned if you install synaptic, searching for packages is ~way~ easier. I just entered "sun" in the search bar and it was right there at the top. sudo install synaptic
    ...and you'll be living the good life. Ric

  10. #10
    Just Joined!
    Join Date
    Jun 2006
    Posts
    8
    I think you're refering to the openJDK which is the knockoff. Installing sun-java6-jdk gets you both the sun-java jtk and the sun-java jre. It's not that much more disk space to install it all and be done with it. Ric

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •