Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
Hmm. That seems fine. Do Code: sudo ifconfig eth1 up sudo iwlist eth1 scan Does that return local wireless networks? Any error? If that works, try Code: killall nm-applet sudo ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651

    Hmm. That seems fine.

    Do
    Code:
    sudo ifconfig eth1 up
    sudo iwlist eth1 scan
    Does that return local wireless networks? Any error?

    If that works, try
    Code:
    killall nm-applet
    sudo service NetworkManager restart
    nm-applet --sm-disable &
    and see if that brings the network manager applet back to the panel.

  2. #12
    Just Joined!
    Join Date
    Jun 2010
    Posts
    20
    It finds the network, no problem there.

    The killall thing went weird. After the restart line it claimed "unrecognized service".

  3. #13
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    So it's just a problem with the panel, notification area, or package. Leaning towards the last due to the weird unrecognized service error.

    Check that it's installed
    Code:
    dpkg -l | grep network-manager
    You said your network was unsecured? It's easy enough to connect from the command line then.
    Code:
    sudo iwconfig eth1 essid "My Network"
    sudo dhclient eth1
    You might want to switch to WICD. Not as nice looking, but many folks find it less problematic.
    Code:
    sudo apt-get install wicd
    Otherwise, I would remove and reinstall the regular network manager. Also delete any config files for it in your home folder. (They'll be hidden.) I don't use it, so I'm not sure where they are located. Look in ~/.config or there may just be a hidden folder ~/.networkmanager.

    The easiest panel fix as well might just be to delete the config files. Again, not sure where they are exactly, but I think ~/.gconf/apps/panel

    Note that the ~ expands to the current user's home directory. If my home is /home/reed, then ~/.config would equal /home/reed/.config.

  4. #14
    Just Joined!
    Join Date
    Jun 2010
    Posts
    20
    I'm starting to think my version of Ubuntu is a special little snowflake...

    The dpkg line wasn't recognised, again. Something with the -1.

    Code:
    ducky@ubuntu:~$ sudo dhclient eth1 
    There is already a pid file /var/run/dhclient.pid with pid 2045 
    killed old client process, removed PID file 
    Internet Systems Consortium DHCP Client V3.1.3 
    Copyright 2004-2009 Internet Systems Consortium. 
    All rights reserved. 
    For info, please visit (URLREMOVED - link to isc's site and the dhcp software)
    
    Listening on LPF/eth1/00:1f:e1:c9:ad:fd 
    Sending on   LPF/eth1/00:1f:e1:c9:ad:fd 
    Sending on   Socket/fallback 
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3 
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6 
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 12 
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15 
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 16 
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9 
    No DHCPOFFERS received. 
    No working leases in persistent database - sleeping.
    Still no internet.

  5. #15
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Should be a lower case l for list, not a 1 on dpkg.

    Post the output of
    Code:
    sudo iwconfig
    Specifically looking at Access Point bit. If it says Not Associated, try again. It can take a couple of tries on occasion, though I've only had that happen with WPA encrypted networks.

    Sometimes helps to bring the interface down and back up again, too.
    Code:
    sudo ifconfig eth1 down
    sudo ifconfig eth1 up
    You can also unload and load the driver module and check dmesg for errors again.
    Code:
    sudo ifconfig eth1 down
    sudo modprobe -r wl
    sudo modprobe wl
    sudo ifconfig eth1 up
    dmesg | tail

  6. #16
    Just Joined!
    Join Date
    Jun 2010
    Posts
    20
    Wait - if dpkg -l | grep network-manager means -l then what's that second l in front of grep?

    I'm going to try again tomorrow, I need to unwind before I toss my laptop out the window.
    Thanks for your help, I really appreciate it, and I hope you can help me solve it.

  7. #17
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    The second symbol is the pipe key or vertical dash. Usually just above the Enter key on most keyboards, on the same key as the backslash.

    It pipes the output of one command into the input of another.

    So dpkg -l lists all installed packages, and grep network-manager searches that output for the string "network-manager". (Grep is a command line text search tool.)

  8. #18
    Just Joined!
    Join Date
    Jun 2010
    Posts
    20
    For some reason this time the iwconfig can't find my network this time...

    Code:
    lo        no wireless extensions. 
    
    eth0      no wireless extensions. 
    
    eth1      IEEE 802.11bg  ESSID:""  
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
              Bit Rate:54 Mb/s   Tx-Power:24 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr:off 
              Encryption key:off 
              Power Managementmode:All packets received 
              Link Quality=5/5  Signal level=0 dBm  Noise level=0 dBm 
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0 
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0

  9. #19
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I would delete the configuration files for networkmanager and the panel in your home folder and see if that resolves the panel/nm-applet issue. Sometimes a corrupted config file can be the problem.

    I'm not sure exactly where they are stored but look in ~/.gnome2 and ~/.config.

    You may want to back those to folders up and just delete them all. You'll lose any custom settings you've made, and it should revert to the defaults.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •