Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, I've just installed Archlinux, with xfce and compiz. I downloaded this theme Code: h ttp://gnome-look.org/content/show.php/Ambiance+Refined+II?content=126580 The theme is correctly installed, but when I run Settings->Appearance, I see no change ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2009
    Posts
    10

    XFCE+Compiz : Installing GTK theme (murrine engine) problem


    Hello,

    I've just installed Archlinux, with xfce and compiz. I downloaded this theme
    Code:
    h ttp://gnome-look.org/content/show.php/Ambiance+Refined+II?content=126580
    The theme is correctly installed, but when I run Settings->Appearance, I see no change at all. So I tried to run in terminal, and here's what I get:
    Code:
    /home/amaury/.themes/AmbianceRefinedII/gtk-2.0/gtkrc:110: error: unexpected identifier `arrowstyle', expected character `}'
    Here's the gtkrc file:
    Code:
    h ttp://pastebin.com/bcKt4kKL
    It's in the murrine engine section (line 110), so I guess the problem comes from here. I have murrine engine (gtk-engine-murrine-0.90.3-2) installed. Any ideas how to fix this?

    PS: I get a message "You are only allowed to post URLs to other sites after you have made 15 posts or more." on this forum, so in the two links above, careful there's a space between the "h" and the double "t" in http.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    The theme it's based on requires the latest git version of the murrine engine, so I would wager this does too. You can install it from the AUR.

  3. #3
    Just Joined!
    Join Date
    Jun 2009
    Posts
    10
    Hello reed9,

    I installed the git version as you told, no more errors when I choose the Ambiance theme, thanks for that.

    But I still don't have the same gtk appearance as displayed on gnome-look. Here's a screenshot of my desktop:
    h ttp://img704.imageshack.us/img704/4519/201007201924251440x900s.png

    Have I missed something ?

  4. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I'm not sure why the menu backgrounds aren't dark, but if you're referring to the window buttons and borders, that's a function of the window manager. In GNOME it's metacity, in XFCE it's xfwm. Xfwm themes are selected in Menu->Settings->Window Manager, I believe.

    But...you're using compiz, which is also a window manager and replaces xfwm. I haven't used compiz for ages, so I'm not sure on that. Do you have compiz-decorator-gtk installed?

  5. #5
    Just Joined!
    Join Date
    Jun 2009
    Posts
    10
    I'm talking about the menu background, the scrollbars, the buttons etc. I don't have compiz-decorator-gtk, I use emerald. I've just tried installing it, but no changes (and it's normal, no? compiz-decorator-gtk is metacity, so changes only the window borders), I uninstalled it now.

  6. #6
    Just Joined!
    Join Date
    Jun 2009
    Posts
    10
    No ideas no-one?
    I've tried with other themes, they all seem not to work. Weird, no?

    Edit: Hey it works now! I've just installed gtk2_prefs and it works like a charm. Weird... but at least it's solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •