Find the answer to your Linux question:
Results 1 to 9 of 9
Thanks for this service! Heads up I am truly an absolute beginner! My acer laptop is sending me a variety of error messages, and I suspect I have only complicated ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    3

    unable to mount everytime


    Thanks for this service! Heads up I am truly an absolute beginner!
    My acer laptop is sending me a variety of error messages, and I suspect I have only complicated this in my attempts to fix. I run Linux mint 8 Helena x64, Linux 2.6.31-14, If you tell me how to I will like to add more info about my os. First off I power on, grub loading, lm leaf graphic, lm green bubbles graphic, then hourglas symbol spinning for eternity, it will stay at this for days if I let it...
    So then I hit ctrl-alt-f1, login&password, then -bash: /dev/null: permission denied, a whole screen of that with a cute non-sequiteur slash-dot-dash animal and $prompt
    I have learned to get past this by as root typing "rm /dev/null" "mknod -m 0666 /dev/null c 1 3"
    then reboot
    init: mountall main process (492) killed with status 3
    mount of filesystem failed
    maintenance shell will now be started
    root for maintenance or ctrl-d which leads to:
    one or more of the mounts listed in /etc/fstab cannot yet be mounted:
    /: waiting for /dev/sda1
    /tmp: waiting for (null)
    swap: waiting for uuid=xxxxxxxxxxx...
    It does not leave this message, so I ESC to recovery shell
    reboot takes me to choose between boot (/dev/sda1) or (recovery mode)
    I choose recovery leads to more options:
    resume, clean, dpkg, netroot, root
    dpkg leads to lots of errors and fails to fetch archives and security
    resume leads to login&password which gets me permission denied again since I've rebooted I workaround that temporarily and resume normal boot, login, no errors, no desktop, sudo mountall, resume normal boot, no errors, login, where to go from here?

    Other:
    I read I could type "startx" to get to desktop but that says "(EE) failed to load module i810 (module does not exist, 0)"
    mountall from other than root leads to a flashy mess of "process 2983: arguments to dbus _pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in fil dbus-pending-call .c line 596"
    "this is normally a bug in some application using the D-Bus library"

    sometimes I am directed to run fsck manually, which leads to me pressing y for yes to all kinds of fixes clears salvages

    I think that is the jyst of it
    now who wants to save me?
    Peace

  2. #2
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    877
    Uh, hold your horses.
    Is this a freshly installed system or your working Mint install has gone bad?

  3. #3
    Just Joined!
    Join Date
    Nov 2009
    Posts
    9
    That looks like one messed up install. You should either re-install if you know this flavor will work with your flavor or find a distribution that fits your hardware profile.

  4. #4
    Just Joined!
    Join Date
    Aug 2010
    Posts
    3
    Not a fresh install. I have been running this os for many months then this happened. My only hope is that this happened for a week or so then worked fine for a month now months of failure!

  5. #5
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    You may have a hard drive or memory error.
    If running fsck resulted in it finding errors,
    you at least know that part of the file system is
    corrupted.

    Boot from your install cd and you should be given
    the option of running memtest, a memory
    tester. If this comes out ok, then boot the cd into
    a live system, assuming this is the type of cd you have.
    See if you can access the contents of your drives
    from the live system. If not, run fsck, then try to
    access drives, back up any data you can, and, unfortunately,
    you will probably have to reinstall the OS.

    There's a good chance that hardware failure is at
    the bottom of it. If you choose to reinstall, make sure you let
    it do a full format, with full testing, to make sure you don't
    have a failing hard drive.

  6. #6
    Just Joined!
    Join Date
    Aug 2010
    Posts
    3
    running memtest from grub bootloader
    but i have no cd
    i installed linux mint from a friends usb pen drive which i no longer have access to.
    how would i recover files, pics, music, from the terminal?
    hoping that is possible, in case it is the hard drive.

  7. #7
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    877
    It depends on what are your options. I'd just toss the dying hard drive and restore from backup. If something is not backed up I'd mount an NFS volume and copy my stuff over there.

  8. #8
    Just Joined! gnuuser's Avatar
    Join Date
    Nov 2009
    Location
    northwestern Pa, usa
    Posts
    69
    its a possibility that you os corrupted after an update or app install
    this sort of thing can happen
    also your hdd could be failing
    you can download the iso from DistroWatch.com: Put the fun back into computing. Use Linux, BSD. or Linux Links - The Linux Portal
    and burn the iso to cd or dvd

    as rcgreen stated boot the livecd and back up your data.
    if you suspect the hard drive may be failing there are many apps that can test your hdd.

    I use d-ban to wipe the hdd(d-ban will perform a disk test!) if you get the message that it finished early due to errors then dont trust the hdd, because its stability is poor

    d-ban can also be downloaded from the above links.
    this is a small file
    burn it to the mini cds

  9. #9
    Just Joined!
    Join Date
    Aug 2008
    Posts
    2

    Fixing up Hal / dbus problems.

    I have found that the only sure way to get it to work is to change the policy in hal.conf. This is brute force since the HalDaemon should permit user access, but it doesn't !@#$@#%! ALL OF THE TIME. So, add this to hal.conf:

    <policy user="name-of-user-to-be-granted-access">
    <allow own="org.freedesktop.Hal"/>
    </policy>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •