Find the answer to your Linux question:
Results 1 to 5 of 5
Hello there, i use the 10.04 ubuntu ,somehow i did something and now the apt-get install command doesn't work.No matter what package i try to download ,there's always a "couldnt ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    19

    problem with apt source


    Hello there,

    i use the 10.04 ubuntu ,somehow i did something and now the apt-get install command doesn't work.No matter what package i try to download ,there's always a "couldnt download all packages run update or --fix...." message.When i scroll up i see that it downloaded some packages but it couldnt find them all.So i thought that i should try a different server.I googled it and found that the server's address is stored in /etc/apt/sources.list .I edited that file and replaced all the deb and deb-src lines with the server's address.I saved that but when i tried to download something(like vlc) i got a "E: Couldn't find package vlc" message.I also tried many different server's but there was no difference.Am i doing it wrong?Should i run a command after editing the /etc/apt/sources.list file?Or didn't i edited the file right?

  2. #2
    Linux User
    Join Date
    Jun 2006
    Location
    Scotland
    Posts
    289
    Copy and paste your sources list here so we can look at it.

  3. #3
    Just Joined!
    Join Date
    Aug 2010
    Posts
    19
    i had to pm the source to you because i cant post url's yet in this forum...so...

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jun 2006
    Location
    Scotland
    Posts
    289
    Your sources list looks mostly OK.

    1) It shows that the CD is still listed as a Repository. You can stop that by putting a # at the beginning of that line.

    2) Do you need the source file lines? Unless you are a computer whizz and have some need of the source files you should stop those (with a # at the beginning of the line again).

    3) Any error messages you get are an important source of information to us and should be Copy and Pasted here in full. Don't just give a part. Give the full error message.

    4) Try to "shake things loose". In a Terminal try all of the following commands:
    sudo dpkg --configure -a
    sudo apt-get -f install
    sudo apt-get --fix-missing install
    sudo apt-get update
    sudo apt-get dist-upgrade
    sudo apt-get clean
    sudo apt-get autoremove
    sudo apt-get update
    (REMEMBER to tell us any error messages in full!)

    (Tip: You do not need to type commands into the Terminal. Highlight the command written on the web page. Move your cursor anywhere in the Terminal and either press CTRL+SHIFT+V together or press your mouse wheel or mouse middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!)

  6. #5
    Just Joined!
    Join Date
    Aug 2010
    Posts
    19
    i think it works now...i ran those commands and now i can download normally.i think i had to run the apt-get update command.thanks for the help arochester

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •