Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Thanks. I'll read up and try to build a new ISO with updated software....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie
    Join Date
    Nov 2007
    Posts
    127

    Thanks. I'll read up and try to build a new ISO with updated software.

  2. #12
    Linux Newbie
    Join Date
    Nov 2007
    Posts
    127
    Forgot to say what I found and how I solved the issue:
    • Nividia refuses to provide the open-source community with the technical infos necessary to write drivers, and instead, provides its own, closed-source drivers.

      The open-source alternative is "nv", which came with the Ubuntu 9.10 liveCD I have. "nv" is now deprecated, and has been replaced with "nouveau". "nouveau" is still not as feature-rich as the Nvidia drivers, but may be good enough for your needs
    • There are actually two drivers for a video card: /lib/modules/2.6.31-20-generic/updates/dkms/nouveau.ko is the driver itself, while /usr/lib/xorg/modules/drivers/nouveau_drv.so is the part required for X
    • Before installing "nouveau", remove "nv" if installed
    • Provided the Linux kernel you have was compiled with support for loading drivers dynamically (I guess all kernels these days are compiled that way), adding a new driver doesn't require recompiling the kernel.
    • Just run "apt-get install" to add a new driver, and edit /etc/modules/ to make this permanent
    • Since Ubuntu 9.10, the X server (Xorg) no longer creates a /etc/X1/xorg.conf by default, and tries to figure out the chipset + monitor you have. It if doesn't work, you can generate your own xorg.conf either manually or through "Xorg -configure" (which will create ~/xorg.conf.new)
    • "gtf 1024 768 75" generates the Modeline instruction (to get 1024x768 @ 75Hz in this example) that you can copy/paste into xorg.conf.

      Caution: In Modeline, ".00" totally crashed my Linux without any error message... :-/
    • While running X, you can check the current configuration with "xrandr"
    • If the screen is not lined up correctly, eg. the picture is a bit too far on the left or on the right, run "xvidtune" (as non-root, at least with the liveCD I have), and make the settings permanent by copy/pasting them in xorg.conf
    • In the liveCD I had at least, to switch from the default US keyboard to the FR keyboard, I have to run "setxkbmap fr" as non-root. I haven't figure out yet how to make this permanent, in both X and in the console
    • Runlevels 3-5 in Ubuntu all boot in X; To boot in text mode, use runlevel 2.


    Here's the whole shebbang:

    Code:
     1. $ setxkbmap fr
     2. $ sudo passwd
     3. $ su -
     4. # lspci | grep VGA
     5. # apt-get update
     6. # apt-get install openssh-server
     7. # apt-get install joe
     8. # apt-get install linux-headers-$(uname -r) linux-libc-dev kernel-package
     9. # apt-get install python-software-properties
    10. # add-apt-repository ppa:bjfs/ppa
    11. # apt-get update
    12. # dpkg -l | grep -i  xserver-xorg-video-nv
    13. # apt-get --purge remove xserver-xorg-video-nv
    14. # apt-get install xserver-xorg-video-nouveau
        
        //If already ran this command, use this to start afresh:
        # aptitude purge dkms
        
    15. # dpkg -l | grep -i "nouveau*"
    16. # dpkg -L xserver-xorg-video-nouveau
    17. # find / -name "nouveau*" | less
    18. //not sure if needed
    19. # depmod
    20. # /etc/init.d/slim start (or some other command to start/stop X cleanly)
    21. # /etc/init.d/slim stop
        
        ALT-F1 to switch to console
         
    22. $ su -
    23. # Xorg -configure
    24. # cp ~/xorg.conf.new /etc/X11/xorg.conf
    25. # gtf 1024 768 75
    26. # joe /etc/X11/xorg.conf
        
        (paste gtf output in section Monitor
        # 1024x768 @ 75.00 Hz (GTF) hsync: 60.15 kHz; pclk: 81.80 MHz
        # Watch out for trailing ".00"...
        # BAD Modeline "1024x768_75.00"  81.80  1024 1080 1192 1360  768 769 772 802  -HSync +Vsync
        Modeline "1024x768_75"  81.80  1024 1080 1192 1360  768 769 772 802  -HSync +Vsync
        
    27. # /etc/init.d/slim start
        (If it doesn't boot start, check /var/log/Xorg.0.log for more information)
    Thanks again.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •