Find the answer to your Linux question:
Results 1 to 8 of 8
Hello I'm trying to install gcc, and am running around in circles it seems. checking for gcc... no checking for cc... no configure: error: no acceptable cc found in $PATH ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4

    [SOLVED] Installing GCC; configure: error: no acceptable cc found in $PATH


    Hello I'm trying to install gcc, and am running around in circles it seems.

    checking for gcc... no
    checking for cc... no
    configure: error: no acceptable cc found in $PATH
    Now I'm not surprised this happens because I don't have gcc installed, but how does one work around it?

    I don't have a CD, and the install came without make (or quite a few other packages) which I've worked around for now, only gcc seems to remain. Downloaded the source files from gcc.gnu.org, unpacked, made an objdir to install into, and ran into this problem. Any ideas?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Which Linux distro are you using?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4
    Debian sorry, obvious thing not to mention.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,279
    Use apt-get or synaptic to install the build-essential package. It includes gcc, make and all the other stuff you need.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  6. #5
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4
    Yep, I had been there already, I think this thread can be trashed anyway, I'll just start anew with installing.

    Anyway, apt-get was leading me along the way to errors and some weird dependency problems, so I went and got the parts of build-essential seperately. Most of them were successful, but gcc complains that I have no c compiler ready for it, which struck me as wrong, anyway, I'll just subscribe this problem to the same dependency problems apt-get confronts me with and as aforementioned start again. I must've gone wrong somewhere doing it manually. Thanks for the help

  7. #6
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    878
    May be obvious, but did you do apt-get update before attempting install?

  8. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute this
    Code:
    su -
    apt-get clean all
    apt-get update
    apt-get install build-essential
    Post exact error message here, if any.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4
    I thank you all for your concern, but the problem has been resolved. My problem was multifold, and at the root of it lay PLESK, allow me to clarify.


    apt-get update would update my openssl (thus rendering PLESK dead, because it is hardcompiled to one openssl version)

    apt-get -f install wanted to remove a ton of packages (and I mean hundreds, it was going to clear out about 280MB and the whole debian install was roughly 300MB in size, this did not look good, so I cancelled that idea)

    apt-get install (anything) gave me errors along the lines of (this is from memory, I did not save them) that libc6 or libstcpp6 depended on lzma and tzdata and these would not be installed. Another error was that it wanted to downgrade dpkg (or dpkg-dev) from 1.14~ to 1.12~. It would then abort the install because there were errors. There were more errors of a similar nature, but these struck me as oddest, and a handful of warnings too.

    Then I started down the road of manually getting and dpkg installing the packages of build-essential. Which came to a halt with gcc.

    So, the reason I made the post was because when attempting to install gcc, it would complain there was no c compiler, which seemed like a stupid sort of infinite loop to me. And I was thus hoping I hade missed the obvious and made a mistake.


    What I did in the end to resolve it was;
    First remove all the packages I had manually installed, because this was going to lead nowhere.

    Second did apt-get update, and replaced all the PLESK packages that had stopped working... which was fun.

    And finally a succesful apt-get install build-essential.


    Now I have a working Debian machine. Thank you all!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •