Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
That's right. You don't have to create a seperate user for samba. It only depends on how you want to use it, but if you just want a public share, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578

    That's right. You don't have to create a seperate user for samba. It only depends on how you want to use it, but if you just want a public share, set guest ok on it. I think that the user that guest is mapped to is nobody by default, but that's configurable. Anyway you'll have to log in as nobody from the Win2K machine and use an empty password in that case.

    Logging from Linux to Win2K? Do you mean mounting a share? In that case, yes, you'll need to use the user name and password corresponding to an accont on the Win2K machine. For example, you can do this:
    Code:
    mount -t smbfs //win2k/share /mnt/smb -o username=win2kuser
    It will then ask you for the password. If you're OK with presenting the password in cleartext, you can add a "password=secret" mount option as well. Useful for /etc/fstab, for example.

  2. #12
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Win2k netbios name = porky
    shared file name = network
    user name = bruce

    I try the following 'mount -t smbfs //porky/network -o username=bruce'
    I get the following error "mount: wrong fs type, bad option, bad superblock on //porky/network, or too many mounted file systems." I know I enabled smbfs under filesytem->network filesystem during kernel compilation. Any ideas?
    The best things in life are free.

  3. #13
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I don't really know. Maybe your version of mount can't handle smbfs. If that's the case, try the program smbmount instead (same usage, just skip -t smbfs).
    If that's not it, try and see if the smbclient program can access that share. Try running "smbclient //porky/network -U bruce".

  4. #14
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Well, it seemed that Debian's samba package only installs the server side tools hence this was the reason why it wasn't working. After installing smbclient and smbfs (used to mount and umount smbfs) both the mount and smbclient methods are working beautifully. I don't know why the package just can't be included in the samba package or the name could be simple as smbmount but I guess this is the downside of installing from packages instead of source.
    However, I do have one more question. When I use 'mount -t smbfs //porky/network /mnt -o username=bruce', it seems that this method only works when I am the root user. Any ideas?
    The best things in life are free.

  5. #15
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Well, naturally mount only allows root to mount filesystem not in /etc/fstab. Probably smbmount is set to be SUID-root, which I'm guessing is a potential securite hazard. I don't know if smbmount is security-enhanced or not.

  6. #16
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Right, I forgot about mount and how it won't allow anything else to be mounted other than the list in /etc/fstab. Thanks.
    The best things in life are free.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •