Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
Urgent Problem with Samba (2.0.7) running on a red hat 7.1 box. Trying to connect to the red hat box from a W2K (sp1) machine. Can ping the linux box ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2003
    Posts
    1

    Samba and W2K...Urgent!!


    Urgent Problem with Samba (2.0.7) running on a red hat 7.1 box. Trying to connect to the red hat box from a W2K (sp1) machine. Can ping the linux box from 2000 by name and ip address..I can see the samba server in network neighbourhood...but when I try to connect it comes back with "the network path cannot be found" ...I can connect to the windows box fronm redhat and mount the windows shares into the linux filesystem...but not vice versa....I am using unencrypted passwords on both machines and have set up the same user accounts on each............please help!!!

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The fact that you can ping it by NetBIOS name and can see it in the network neighbourhood only indicates that nmbd is running. Are you sure that smbd is running?

  3. #3
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Check in your /etc/samba/smb.conf file that you have specified right directorys under you specific shares and that you have right permissions on the local directorys. Have you specified that group only should be able to access the shares or do you have guest ok?? if you want you can look at my smb.conf file that workes in a windows domain envirenoment you can look on http://www.utterberg.com under howtos section.

    Regards

    Regards

    Andutt

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    smb.conf

    I just installed samba and although the Win2K machine can see the machine running samba, it cannot access it. I get an error stating that it needs a username and a password. What do I do to set this up on samba? Under one of the sections in smb.conf, I set 'guest ok = yes' and that doens't seem to have an effect here.
    Looking through smb.conf files, I see headers with square brackets. What are these things and what purpose do they serve?
    The best things in life are free.

  6. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Samba always requires user name and password, there's no helping that. If you set guest ok to yes, it just means that the guest account can be accessed with an empty password (not no password). Just enter guest or nobody and leave the password field empty and connect.
    You can also specify your user account and password, provided that you've added a LanMan encrypted password using smbpasswd.
    Remember to set encrypt passwords to yes as well.
    The square headers defines different shares, except the [global] header, under which you define your global options. See smb.conf(5) for more info.

  7. #6
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    When adding users for samba, do I add users to the local machine hosting smbd?
    The best things in life are free.

  8. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That's right. The thing is that samba needs the passwords encrypted in the LanMan scheme, and that's the only thing that you have to add. The rest of the accounting information is taken from /etc/passwd. These are stored in /etc/samba/smbpasswd by default.

  9. #8
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    So let me put this in plain words. I have a Win2k machine that wants to access data from my linux machine. If I add a user called venom with a certain password, do I use that account to access my linux machine? Does my account from Win2k matter at all?
    Furthermore, creating the user venom now leaves a /home/venom directory with the appropriate files and scripts. What I misunderstood with samba (from reading the old book from O'Reily) was that the account from Windows machine would automatically be used to log into samba.
    The best things in life are free.

  10. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    No, your Win2k account doesn't matter at all. You specify the account to use on the remote machine.
    It is the account that you created that is used to log into using SMB, it's just that Samba also needs the LanMan encrypted password to be able to authenticate the user. Add it with "smbpasswd -a venom", and then type in the password again. The reason why you have to do this is that UNIX encrypts passwords with MD5 nowadays, while Windows uses some other home brew encryption. Since neither the Windows encryption nor the MD5 encryption can be decrypted again (the Windows encryption is pretty easy to break from what I've read, but anyway it's not supposed to be broken), Samba will need the LanMan encryption as well to be able to authenticate users. All the rest of the information used for the account comes from the UNIX account, though.

  11. #10
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Ah, I feel some sense of clarity. I dunno what this forum would do without you.
    I don't see a point in making a new user just for samba. This will only take up space that I'll never really use other than samba so is it alright to set 'guest ok' to yes and login using guest or nobody?
    Now, what about loging from the linux machine to win2k? I already have a username setup on win2k from my other win2k machine (well, the linux box is a dual boot). Can I simply use that information to logon?
    The best things in life are free.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •