Find the answer to your Linux question:
Results 1 to 7 of 7
Hello all, I am trying to get my built in webcam working on my Toshiba satellite 500 running debian lenny. It worked fine at the beginning, with a fresh kernel ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9

    Angry No webcam (uvcvideo missing from new kernel)


    Hello all,

    I am trying to get my built in webcam working on my Toshiba satellite 500 running debian lenny. It worked fine at the beginning, with a fresh kernel (2.6.26-2). The uvcvideo module loaded fine and cheese, gstreamer-properties all gave me a nice picture of myself.....

    heres the modules loaded in nicely in the old kernel:

    $ lsmod | grep video
    uvcvideo 45800 0
    compat_ioctl32 1312 1 uvcvideo
    videodev 27520 1 uvcvideo
    v4l1_compat 12260 2 uvcvideo,videodev
    video 16464 0
    output 2912 1 video
    usbcore 118224 6 uvcvideo,usblp,usb_storage,usbhid,ehci_hcd
    thermal_sys 10856 4 video,thermal,processor,fan

    in my new kernel, which I compiled myself from source (2.6.32.10), the webcam doesnt work at all. gstreamer-properties and cheese just show me a screen with coloured horizontal bands. I notice that in my new kernel, I do not have uvcvideo.

    $ lsmod | grep video
    video 14869 0
    output 1200 1 video
    thermal_sys 9610 4 video,processor,thermal,fan

    so I guess thats my problem.

    I have done some mighty searching on this issue. I have downloaded various packages, none of which seemed to help, and some of which didn't even install properly. But I don't want to give up because the webcam worked before in the old kernel, so in theory, it is supported somehow, somewhere...

    Does anyone have any idea how I can get hold of the uvcvideo drivers I had loaded in my original kernel?

    my webcam by the way is a built in chicony usb
    $ lsusb
    Bus 001 Device 003: ID 04f2:b128 Chicony Electronics Co., Ltd

    I dont think this will help much - my problem is lack of uvcvideo, not webcam make. I include just in case...

    thanks in advance

    Rich

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,574
    Before you built the kernel, did you run "make config" or "make xconfig" and tell it to install/build the appropriate drivers? This is a common mistake when building new kernels.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9
    Rubberman, thanks for getting back to me,

    Here's the procedure I followed (I built the kernel to get sound working):
    at which point exactly would I need to run make config or make xconfig to get these drivers installed?

    ------------------------------------------------------------------------
    step 1. get new kernel source file "linux-2.6.32.10.tar.bz2" from kernel website.

    get necessary packages-
    #apt-get install kernel-package ncurses-dev bzip2 module-init-tools
    initramfs-tools procps fakeroot
    #apt-get install libgtk2.0-dev libglib2.0-dev libglade2-dev libqt3-mt-dev

    (these last for gconf configuration tool, among other things)

    step 2. Move into home directory where tarred kernel source file is and untar
    #tar xjf linux-2.6.32.10.tar.bz2

    step 3. copy the existing configuration to the new kernel source directory:
    #cp /boot/config-$(uname -r) ./.config
    (I checked that it had worked with ls -al)

    step 4: CONFIGURATION of new kernel with gconfig (I found gconfig helpful, better I think that menuconfig because it conbines a good graphic interface with full information about each individual configuration file (the .config file can also be viewed in a text editor; I did "pico ./config"). In the Device Drivers section, I went to (I dont remember the exact headings)--sound cards--PCI devices--Linux Advanced Sound Architecture. and then scrolled down through the manufacturers to--Intel HD Audio tab. Here, the various configuration settings are listed. The one i needed, SND_HDA_CODEC_INTELHDMI was already selected, marked NEW in the 2.6.32.10 kernel. I checked all the INTEL HD Audio options, just in case, and saved the configuration.

    step 5: clean up
    #make-kpkg clean

    step 6: make multiprocessing work:
    #export CONCURRENCY_LEVEL=2

    step 7: compile
    #make-kpkg --rootcmd fakeroot --initrd --revision=custom.001
    kernel_image kernel_headers

    step 8. solve Lguest error:

    after around an hour of compiling, no .deb packages were built, and the system through up an lguest error:
    "cc -m32 -Wall -Wmissing-declarations -Wmissing-prototypes -O3 -I../../include -I../../arch/x86/include -U_FORTIFY_SOURCE lguest.c -o lguest
    lguest.c:21:25: error: sys/eventfd.h: No such file or directory
    lguest.c: In function ‘create_thread’:
    lguest.c:1021: warning: implicit declaration of function ‘eventfd’
    make: *** [lguest] Error 1

    To solve this problem I opened "Documentation/lguest/Makefile in nano/pico
    and changed the line that reads all: lguest by simply removing the word "lguest"." (solution from various websites)
    I then saved the file and re-issued the compile command.

    #make-kpkg --rootcmd fakeroot --initrd --revision=custom.001
    kernel_image kernel_headers

    this built me the .deb packages correctly.

    step 9. move to the directory where the .deb package (the newly compiled kernel 2.26.32.10 is)
    and install the kernel
    #cd ..
    # dpkg -i *.deb

    Step 10: I rebooted, and selected the new kernal at the boot prompt. It gave me a couple of warnings, but loaded successfully.

    ----------------------------------

    Thanks!

  4. #4
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9

    [SOLVED] No webcam (uvcvideo missing from new kernel)

    Hi there everyone.

    I've solved the webcam problem by upgrading to squeeze. I'm very happy with it. I guess this is a lesson for me in trying to use a new laptop (Toshiba staellite L500) with an old-ish distribution. I began installing lenny, but couldnt get sound working or radeon graphics for my monitor. I upgraded the kernel to 2.26.30.10, which solved the sound problem, but rodgered the webcam.

    In squeeze, I now have webcam supported (gives correct output in gstreamer-properties and works with skype), sound fully functioning and radeon hd graphics supported except for a bit of tweaking to install firmware-linux-nonfree (I'm now using the radeon driver, with a bit of non-free stuff, rather than the wholly proprietory ATI catalyst driver).

    the only thing that didnt work out-of-the box was wifi. I just wanted to comment that, for once, more google searching proved a hindrance, not a help. I got wifi working through installing rtl8192se wifi driver from the realtek website, as before with lenny, and then just modifying the /etc/network/interfaces file with the ESSID and WPA-PSK passcode. Internet worked, but in fits and starts. Google searching led me to the conclusion that I needed to install wpa_supplicant and various sites advised using the network-manager. I spent many fruitless hours trying to get wpa_supplicant working, and in the end just gave up, with internet still very jerky and not satisfactory.

    had a brainwave this morning and uninstalled network-manager.

    Internet now runs like a dream. & finally, in response to various comments I've seen posted about the fact that /etc/init.d/networking restart has been deprecated in Squeeze, well its true, I did get this message too, but whats the big deal? you can stop networking with /etc/init.d/networking stop and start it again with /etc/init.d/networking start, so it hasnt bothered me.

    In summary, lessons learnt:

    1. if you have a new laptop, get the newest version/distribution, even if its testing. Don't be conservative like I was and install stable, you'll give yourself a headache!

    2. when it comes to networking, do it by hand. Tools like network-manger just confuse things. I'm sure wpa-supplicant has been useful for some; it wasn't a bit of help to me, I just installed drivers and configured /etc/network/interfaces.

    Thanks to everyone whose helped me out these few months...

    Rich

  5. #5
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,574
    Well congratulations, you have just won the computer version of "Whack-a-Mole"!

    Sometimes you just have to get back to basics, which you did, and you got it working. It is broadly recognized that the user experience in getting wireless working for all but standard cruft is somewhat lacking in Linux currently (sigh). Personally, I haven't had any problems with my laptops or 3rd party cruft with any version of Ubuntu since 7.04, but then Dell systems are pretty well supported due to their popularity. All the builtin stuff (WiFi and Bluetooth), my Sierra Wireless CDMA Sprint USB modem, my nameless webcam, a Belkin bluetooth USB dongle, and my tethered Android 2.2 3G phone all ran out-of-the-box. I'm currently running Ubuntu 9.04 and it hasn't glitched once on any of that stuff. Just lucky I guess...
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  6. #6
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9
    yes, Dell systems are good, generally. My old machine was a del inspiron, very solid, still running actually and now 8 years old (but the 256 mb of RAM it has is a bit too slow for what I want nowadays). I wavered between getting a Dell again and between this Toshiba & finally went for the toshiba on the basis of its multiprocessors. It is fast, there's no denying it. But, yes as far as support for various devices goes, I think I would have been better off with a dell after all (Toshiba website itself is awful for us guys - they do have a linux section but its pretty much empty).
    Nevermind, laptop works now, all of it finally. Now (3 months later) I can get on with some work

    ciao

    rich

  7. #7
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,574
    If you are in the USA, there is a great little computer company in Berkeley California called ZaReason - ZaReason, Inc. :: Laptops, Desktops, Servers, and Peripherals Designed for Ubuntu Linux - that sells only Linux systems from netbooks to rack-mounted servers. All the stuff is guaranteed to work, and you can get a number of Linux distributions installed including Ubuntu, Fedora, Debian, and Mint. Their prices are competitive, though at the server/workstation level I can build a high-end system from components quite a bit cheaper. Next year when I get a new laptop, I will probably purchase from them, simply because I know I won't have to worry whether or not any of the built-ins will work.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •