Find the answer to your Linux question:
Results 1 to 6 of 6
I have a MacBook but cannot type a hash/sharp/pound sign while in VI on it. On the Mac keyboard alt-3 has always been this key but it doesn't work in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2010
    Posts
    4

    [SOLVED] comments, mac keyboard


    I have a MacBook but cannot type a hash/sharp/pound sign while in VI on it. On the Mac keyboard alt-3 has always been this key but it doesn't work in VI. I'm having to copy and paste the symbol, which is a real pain. Does anybody know a solution?

  2. #2
    Linux Engineer GNU-Fan's Avatar
    Join Date
    Mar 2008
    Posts
    935
    What do you get when you press shift-3?
    Debian GNU/Linux -- You know you want it.

  3. #3
    Just Joined!
    Join Date
    Sep 2010
    Posts
    4
    the GBP currency sign.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2010
    Posts
    4
    Ah, sorry. Perhaps it's the wrong forum. I think it's an issue with the Mac terminal with a UK keyboard rather than VI. The # key doesn't seem to be available. I think the only way is to cut and paste it.

  6. #5
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    877
    If this is an X terminal you could use a custom keymap and redefine your keys to your liking.

  7. #6
    Just Joined!
    Join Date
    Sep 2010
    Posts
    4
    Thank you. I don't understand about custom keymaping but it prompted me to go to the terminal settings, I unclicked the 'use option as a meta key' and it solved the problem. What a relief, thanks. I should have thought of looking at the settings before.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •