Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Does Linux need video card support?


    Was running Ubuntu 10.04 on a machine with an Nvidia GeForce X1300 card. The card went bad so I went back to the integrated video on the motherboard. Now Ubuntu won't boot and I can't even do a fresh install. Does Linux have to be supported by the video card? Thanks.

  2. #2
    Did you go into bios and enable onboard video before you booted Ubuntu?
    I refuse to let fear and fear of others rule my life. It puts my humanity at risk.
    Accepting Death is the only way to stay alive.

  3. #3
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,907
    What do you mean by wont boot?

    If you get a black screen, and you had the nvidia drivers installed, you may be using the wrong driver. At the black screen, press Ctrl + Alt + F1 to drop to a console and then log in as yourself.

    run the following command

    sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.saved

    That's a capital x and two ones. This command will rename your X config file forcing an auto-detect when you reboot which you can do by running the following command:

    sudo shutdown -r now
    Last edited by elija; 10-10-2010 at 10:22 AM. Reason: correct switch in shutdown command
    Should you be sitting wondering,
    Which Batman is the best,
    There's only one true answer my friend,
    It's Adam Bloody West!


    The Fifth Continent

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    13,750
    It is very likely (almost a certainty) that your xorg.conf file is not configured properly for the on-board video. As mentioned by rokytnji, you first need to enable the on-board video in the BIOS, then when you boot it should put you into a text-mode login since it won't be able to start the X server. You then need to alter your /etc/X11/xorg.conf file by running the command "Xorg -configure". That will probe your hardware and write a new xorg.conf file for you. You should then be able to start the X server with the command "startx".
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •