Find the answer to your Linux question:
Results 1 to 5 of 5
Hi to everyone and thanks in advance for your help. I did find a few similar topics but nothing that resolved this, so I'm starting a new thread. I am ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010

    VSFTPD - 553 Could not create file

    Hi to everyone and thanks in advance for your help. I did find a few similar topics but nothing that resolved this, so I'm starting a new thread.

    I am trying to use cron and FTP to backup files regularly from my main server to a backup server. The backup server was a "bare bones" setup with no control panel or even FTP. It is running CentOS 5.3.

    I installed VSFTPD which appears to be running OK and I can connect via FTP from my other server, but when I try to run my backup script (it uses mput) I get a "553 Could not create file" error.

    Some relevant info:

    The user I have created for this is "ftz" with home directory /home/ftz/

    Running ls -l shows:
    drwxrwxrwx 3 ftz ftz 4096 Dec 18 07:46 ftz

    so permissions and directory ownership don't seem to be the problem.

    vsftpd.conf was left in default form:

    # Example config file /etc/vsftpd/vsftpd.conf
    # The default compiled in settings are fairly paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    # Please see vsftpd.conf.5 for all compiled in defaults.
    # READ THIS: This example file is NOT an exhaustive list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
    # capabilities.
    # Allow anonymous FTP? (Beware - allowed by default if you comment this out).
    # Uncomment this to allow local users to log in.
    # Uncomment this to enable any form of FTP write command.
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    # Uncomment this to allow the anonymous FTP user to upload files. This only
    # has an effect if the above global write enable is activated. Also, you will
    # obviously need to create a directory writable by the FTP user.
    # Uncomment this if you want the anonymous FTP user to be able to create
    # new directories.
    # Activate directory messages - messages given to remote users when they
    # go into a certain directory.
    # The target log file can be vsftpd_log_file or xferlog_file.
    # This depends on setting xferlog_std_format parameter
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    # If you want, you can arrange for uploaded anonymous files to be owned by
    # a different user. Note! Using "root" for uploaded files is not
    # recommended!
    # The name of log file when xferlog_enable=YES and xferlog_std_format=YES
    # WARNING - changing this filename affects /etc/logrotate.d/vsftpd.log
    # Switches between logging into vsftpd_log_file and xferlog_file files.
    # NO writes to vsftpd_log_file, YES to xferlog_file
    # You may change the default value for timing out an idle session.
    # You may change the default value for timing out a data connection.
    # It is recommended that you define on your system a unique user which the
    # ftp server can use as a totally isolated and unprivileged user.
    # Enable this and the server will recognise asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial). Not enabling it,
    # however, may confuse older FTP clients.
    # By default the server will pretend to allow ASCII mode but in fact ignore
    # the request. Turn on the below options to have the server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that on some FTP servers, ASCII support allows a denial of service
    # attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
    # predicted this attack and has always been safe, reporting the size of the
    # raw file.
    # ASCII mangling is a horrible feature of the protocol.
    # You may fully customise the login banner string:
    #ftpd_banner=Welcome to blah FTP service.
    # You may specify a file of disallowed anonymous e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    # (default follows)
    # You may specify an explicit list of local users to chroot() to their home
    # directory. If chroot_local_user is YES, then this list becomes a list of
    # users to NOT chroot().
    # (default follows)
    # You may activate the "-R" option to the builtin ls. This is disabled by
    # default to avoid remote users being able to cause excessive I/O on large
    # sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a strong case for enabling it.
    # When "listen" directive is enabled, vsftpd runs in standalone mode and 
    # listens on IPv4 sockets. This directive cannot be used in conjunction 
    # with the listen_ipv6 directive.
    # This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
    # sockets, you must run two copies of vsftpd whith two configuration files.
    # Make sure, that one of the listen options is commented !!
    If anyone has any ideas on what the problem could be, I would love to hear from you. Please note that I am kind of a noob so speak sloooowly .

    Thanks again to anyone that can offer some help.

  2. #2
    Just Joined!
    Join Date
    Dec 2010
    553 Permission Denied


    * CuteFTP Home (All Versions)
    * CuteFTP Professional (All Versions)


    When attempting to upload a file to the remote FTP site, a 553 error code is encountered, resulting in an error message similar to the following example:

    COMMAND:> STOR your file.ext
    STATUS:> Connecting FTP data socket...
    553 your file.ext: Permission denied.
    ERROR:> Access denied.


    This error is not caused by CuteFTP. The 553 error code is coming directly from the remote FTP server. The file name is not allowed.

    Many FTP servers have restrictions on file names. If your file name contains special characters, symbols, or spaces in the file name, it might be rejected by the remote FTP server. In the example above, the file name was rejected because of a space. The remote FTP site may also be rejecting a particular file based on the file type or extension.


    If your file name contains special characters, symbols, or spaces in the file name, you will need to rename it before you can upload the file. Rename the file using only alpha-numeric characters and no spaces. For more information, see Best Practices for Naming Files.

    Note: If you change the file name, you may also need to change links in Web pages that point to that file name as well.

  3. #3
    Just Joined!
    Join Date
    Dec 2010
    Thanks for your reply Maki, but I am not using CuteFTP, and there is no weirdness in the file name - I am just transfering over a "filename.tar.gz" backup file (no spaces or unusual characters in the filename).

  4. $spacer_open
  5. #4
    Just Joined!
    Join Date
    Jan 2011
    are you connecting to the ftp server as user ftz ?

    can you create a file as user ftz in /home/ftz while logged into that server?

    is selinux set to permissive mode (run sestatus) ?

    is there anything in the logs ?

  6. #5
    Just Joined!
    Join Date
    Dec 2010
    Thanks for your help. In the meantime, I actually found a much better solution, using rsync over SSH, which is much more efficient, secure and easy to set up.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts