I'm a newbie here as well as with linux. I'm using Fedora 14 i686.

My problem is I've installed VMware Workstation for virtualization. This is the version that I installed 7.1.3-324285.i386. It installed trouble-free but when I run the program "VMware Kernel Module Updater", a window shows up asking for the location of Kernel Headers I've no idea where it is location in the file system. So, kindly help me out with this problem.

And also I installed Kernel Source Code as suggested over the following site:


After completing all the steps suggested in the above site, again I tried running VMware workstation and once again it asks for the same thing Kernel Module.

And also I tried the steps suggested in the following blog


When I issue this command <sudo vmware-modconfig --console --install-all> it give me this message <gcc and kernel headers must be installed>. Even though all GCC's and Kernel Headers have been installed and they are up-to-date.

So, please please guide me through my problem and I will appreciate if you can explain the process in detail and in steps. As I said I'm totally new to Fedora and Linux.

Thank you,