Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
I'm not sure... maybe /proc/isapnp doesn't show up at all if you have no ISA PNP devices. I haven't tried it on a computer without ISA PNP before. Anyway, you ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578

    I'm not sure... maybe /proc/isapnp doesn't show up at all if you have no ISA PNP devices. I haven't tried it on a computer without ISA PNP before.
    Anyway, you shouldn't have to comment out anything for modprobe to work. What errors did it give you?

  2. #12
    Just Joined!
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    20
    Well... it doesn't error - it seems to do what it's told - but afterwards, sound is still not working ..

  3. #13
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Check with lsmod what modules are loaded.

  4. #14
    Just Joined!
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    20
    Well, I ran sndconfig yet another time to learn what modules should be active.

    After sndconfig, update-modules - before playing a sound:
    Code:
    Module                  Size  Used by    Not tainted
    sb_lib                 32256   0 
    uart401                 6016   0  [sb_lib]
    sound                  52876   0  [sb_lib uart401]
    soundcore               3236   2  [sb_lib sound]
    nls_cp437               4384   2  (autoclean)
    parport_pc             12900   0  (unused)
    parport                12864   0  [parport_pc]
    af_packet               8488   0  (unused)
    During the playing of sound:
    Code:
    Module                  Size  Used by    Not tainted
    sb                      7328   1  (autoclean)
    sb_lib                 32256   0  [sb]
    uart401                 6016   0  [sb_lib]
    sound                  52876   1  [sb_lib uart401]
    soundcore               3236   4  [sb_lib sound]
    nls_cp437               4384   2  (autoclean)
    parport_pc             12900   0  (unused)
    parport                12864   0  [parport_pc]
    af_packet               8488   0  (unused)
    After playing a sound:
    Code:
    Module                  Size  Used by    Not tainted
    sb                      7328   0  (autoclean)
    sb_lib                 32256   0  [sb]
    uart401                 6016   0  [sb_lib]
    sound                  52876   0  [sb_lib uart401]
    soundcore               3236   4  [sb_lib sound]
    nls_cp437               4384   2  (autoclean)
    parport_pc             12900   0  (unused)
    parport                12864   0  [parport_pc]
    af_packet               8488   0  (unused)
    I edited /etc/modules so all these modules (and no others) are loaded - but it still doesn't work...

    Right now, in a non-action situation, lsmod reports:
    Code:
    Module                  Size  Used by    Not tainted
    parport_pc             12900   0  (unused)
    parport                12864   0  [parport_pc]
    af_packet               8488   0  (unused)
    nls_cp437               4384   2  (unused)
    sb                      7328   1
    sb_lib                 32256   0  [sb]
    uart401                 6016   0  [sb_lib]
    sound                  52876   0  [sb_lib uart401]
    soundcore               3236   4  [sb_lib sound]
    Can you give advise on what to do?

  5. #15
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What happens when you try to play a sound? Does it appear to be playing, but no sound is coming out of your speakers? In that case, it could just be the mixer settings. Use aumix to set them right if that's it.

  6. #16
    Just Joined!
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    20
    Hello,

    Well, each time I try sound, I try with the same .ogg file.
    Ogg says it will use Device "OSS audio driver output" (which I believe is the one from the sb module) and some info about off (author, comments)
    After that, it says: "Error: Cannot open device oss"


    Today, I noticed the weirdest I ever saw on this: I had moved the sndconfig to the /root dir (so it wasn't loaded) and placed it again in /etc/modules.conf - and then sound worked... that is, untill I logged off. That temp. working thing was after a reboot, so I think nothing of the sndconfig can be in memory

    Could I somehow, eh, use this behavior, like, removing the sndconfig stuff from memory and reloading it? The problem is ofcourse it would have to be done on each login (even when I log off of gnome. and log in again - sound is gone !)

    Thanks,

    Joris

  7. #17
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I'm really running out of ideas here. I don't really know what that sndconfig program does, that's the thing.
    Maybe someone who knows more about Debian can help you. bpark? craig_mcd?

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •