Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Hello everybody, I have this problem: I'm trying to get sound support working on a laptop which is running Debian. I found the computer has a ESS 1869 sound card. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    20

    sndconfig problems: sound only works until reboot


    Hello everybody,

    I have this problem:
    I'm trying to get sound support working on a laptop which is running Debian. I found
    the computer has a ESS 1869 sound card.

    I searched on the web and found a few pages mentioning
    sndconfig. I gave it a try and got sound working using
    the Soundblaster config;

    The problem is, for some reason sound is NOT working
    when the computer is booted again. The only way I
    found to get it working again is, commenting out
    sndconfig, updating modules and running sndconfig again - ofcourse I want sound to work without any additional work!

    Can anybody tell me what I should do to make the sound
    work allways ? I think some necessary module must be inactive or something like that - the problem is, sndconfig isn't telling me what module(s) it's activating

    Thanks very much

    Joris

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What changes does sndconfig do to what files?

  3. #3
    Just Joined!
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    20
    Quote Originally Posted by Dolda2000
    What changes does sndconfig do to what files?
    Well, that's the problem, kind of... I don't know what the thing is doing exactly, because it doesn't show any technical details at all - and I don't know the program well enough to guess..

    What I do know is, it creates two files, which are pasted below. I hope this is enough info to help me - I really don't know what to do and I want this to work !

    1. /etc/sysconfig/soundcard
    Code:
    # THIS FILE IS WRITTEN BY SNDCONFIG
    # PLEASE USE SNDCONFIG TO MODIFY
    # TO CHANGE THIS FILE!
    # There should be no spaces at the start of a line
    # or around the '=' sign
    CARDTYPE=SBORIG
    -----------------

    Now, I don't know what this file is supposed to do - maybe that's the problem
    Note also, that I've got many difficulties at getting sndconfig to work - especially as it seems to stop configuring itself if it finds modules are allready running with an error message about /dev/audio (I have no idea why)

    2. /etc/modules.conf (from a boot time when that problem wasn't there as I hadn't figured out the modules should be in /etc/modules, yet)

    Well, actually, the file sndconfig generates is /etc/modutils/sndconfig but I don't have it right now

    Code:
    ### This file is automatically generated by update-modules"
    #
    # Please do not edit this file directly. If you want to change or add
    # anything please take a look at the files in /etc/modutils and read
    # the manpage for update-modules.
    #
    ### update-modules: start processing /etc/modutils/0keep
    # DO NOT MODIFY THIS FILE!
    # This file is not marked as conffile to make sure if you upgrade modutils
    # it will be restored in case some modifications have been made.
    #
    # The keep command is necessary to prevent insmod and friends from ignoring
    # the builtin defaults of a path-statement is encountered. Until all other
    # packages use the new `add path'-statement this keep-statement is essential
    # to keep your system working
    keep
    
    ### update-modules: end processing /etc/modutils/0keep
    
    ### update-modules: start processing /etc/modutils/actions
    # Special actions that are needed for some modules
    
    # The BTTV module does not load the tuner module automatically,
    # so do that in here
    post-install bttv insmod tuner
    post-remove bttv rmmod tuner
    
    
    ### update-modules: end processing /etc/modutils/actions
    
    ### update-modules: start processing /etc/modutils/aliases
    # Aliases to tell insmod/modprobe which modules to use 
    
    # Uncomment the network protocols you don't want loaded:
    # alias net-pf-1 off		# Unix
    # alias net-pf-2 off		# IPv4
    # alias net-pf-3 off		# Amateur Radio AX.25
    # alias net-pf-4 off		# IPX
    # alias net-pf-5 off		# DDP / appletalk
    # alias net-pf-6 off		# Amateur Radio NET/ROM
    # alias net-pf-9 off		# X.25
    # alias net-pf-10 off		# IPv6
    # alias net-pf-11 off		# ROSE / Amateur Radio X.25 PLP
    # alias net-pf-19 off		# Acorn Econet
    
    alias char-major-10-175	agpgart
    alias char-major-10-200	tun
    alias char-major-81	bttv
    alias char-major-108	ppp_generic
    alias /dev/ppp		ppp_generic
    alias tty-ldisc-3	ppp_async
    alias tty-ldisc-14	ppp_synctty
    alias ppp-compress-21	bsd_comp
    alias ppp-compress-24	ppp_deflate
    alias ppp-compress-26	ppp_deflate
    
    # Crypto modules (see http://www.kerneli.org/)
    alias loop-xfer-gen-0	loop_gen
    alias loop-xfer-3	loop_fish2
    alias loop-xfer-gen-10	loop_gen
    alias cipher-2		des
    alias cipher-3		fish2
    alias cipher-4		blowfish
    alias cipher-6		idea
    alias cipher-7		serp6f
    alias cipher-8		mars6
    alias cipher-11		rc62
    alias cipher-15		dfc2
    alias cipher-16		rijndael
    alias cipher-17		rc5
    
    
    ### update-modules: end processing /etc/modutils/aliases
    
    ### update-modules: start processing /etc/modutils/alsa-path
    # Debian ALSA modules path
    # Do not edit this unless you understand what you're doing.
    path=/lib/modules/`uname -r`/alsa
    
    ### update-modules: end processing /etc/modutils/alsa-path
    
    ### update-modules: start processing /etc/modutils/apm
    alias char-major-10-134	apm
    alias /dev/apm_bios		/dev/misc/apm_bios
    alias /dev/misc/apm_bios	apm
    
    ### update-modules: end processing /etc/modutils/apm
    
    ### update-modules: start processing /etc/modutils/irda
    alias tty-ldisc-11 irtty
    alias char-major-161 ircomm-tty
    alias char-major-60 ircomm_tty
    
    # for dongle
    alias irda-dongle-0 tekram
    alias irda-dongle-1 esi
    alias irda-dongle-2 actisys
    alias irda-dongle-3 actisys
    alias irda-dongle-4 girbil
    alias irda-dongle-5 litelink
    alias irda-dongle-6 airport
    alias irda-dongle-7 old_belkin
    
    # for FIR device
    #alias irda0 nsc-ircc dongle_id=0x09
    
    ### update-modules: end processing /etc/modutils/irda
    
    ### update-modules: start processing /etc/modutils/paths
    # This file contains a list of paths that modprobe should scan,
    # beside the once that are compiled into the modutils tools
    # themselves.
    
    
    ### update-modules: end processing /etc/modutils/paths
    
    ### update-modules: start processing /etc/modutils/ppp
    alias /dev/ppp          ppp_generic
    alias char-major-108    ppp_generic
    alias tty-ldisc-3       ppp_async  
    alias tty-ldisc-14      ppp_synctty
    alias ppp-compress-21   bsd_comp   
    alias ppp-compress-24   ppp_deflate
    alias ppp-compress-26   ppp_deflate
    
    ### update-modules: end processing /etc/modutils/ppp
    
    ### update-modules: start processing /etc/modutils/setserial
    #
    # This is what I wanted to do, but logger is in /usr/bin, which isn't loaded
    # when the module is first loaded into the kernel at boot time!
    #
    #post-install serial /etc/init.d/setserial start | logger -p daemon.info -t "setserial-module reload"
    #pre-remove serial /etc/init.d/setserial stop | logger -p daemon.info -t "setserial-module uload"
    #
    alias /dev/tts          serial
    alias /dev/tts/0        serial
    alias /dev/tts/1        serial
    alias /dev/tts/2        serial
    alias /dev/tts/3        serial
    post-install serial /etc/init.d/setserial modload > /dev/null 2> /dev/null
    pre-remove serial /etc/init.d/setserial modsave  > /dev/null 2> /dev/null
    
    ### update-modules: end processing /etc/modutils/setserial
    
    ### update-modules: start processing /etc/modutils/sndconfig
    alias sound-slot-0 sb
    post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
    pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
    options sound dmabuf=1
    alias synth0 opl3
    options opl3 io=0x388
    options sb io=0x220 irq=5 dma=1
    
    ### update-modules: end processing /etc/modutils/sndconfig
    
    ### update-modules: start processing /etc/modutils/toshutils
    alias char-major-10-181 toshiba
    
    ### update-modules: end processing /etc/modutils/toshutils
    
    ### update-modules: start processing /etc/modutils/arch/i386
    alias parport_lowlevel parport_pc
    alias char-major-10-144 nvram
    alias binfmt-0064 binfmt_aout
    alias char-major-10-135 rtc
    
    ### update-modules: end processing /etc/modutils/arch/i386

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    In that line saying "options sb ...", try adding "esstype=1869" to the end, then try rebooting and see what it says.
    What error msgs do you get at boot time, btw.?

  5. #5
    Just Joined!
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    20
    Hello Dolda2000,

    Thank you for your reply.
    I added the text about esstype=1869 - but sound still doesn't work

    In my /etc/modules I've got the following:
    • af_packet
      parport
      parport_pc
      soundcore
      snd
      opl3
      sound
      sb
    When I want to use sndconfig, the last two of the list must be commented out otherwise the sound test fails with an obscure error on /dev/audio, even though I allways run sndconfig under root - I have no idea why this happens

    When they are commented out, I get an modprobe error on sound-services-0-3 - I think that's the sound module but I can't tell for sure - otherwise, there are no errors on sound modules

    BTW, I got errors on pcmcia - which I think was not compiled into my kernel - could that be the cause of these problems ?

    Thanks for your help,

    Joris

  6. #6
    Just Joined!
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    20

    What's going on??

    Hello everybody,

    As nobody responded after that last mail, I did searches on google again, found stuff like different people having different configurations, which I tried - but so far everything failed

    I found the program lspci is supposed to tell usefull information - unfortunately I don't know what any of this means
    Code:
    00:00.0 Host bridge: OPTi Inc. 82C701 [FireStar Plus] (rev 32)
    00:01.0 ISA bridge: OPTi Inc. 82C700 (rev 31)
    00:0a.0 CardBus bridge: Texas Instruments PCI1131 (rev 01)
    00:0a.1 CardBus bridge: Texas Instruments PCI1131 (rev 01)
    00:12.0 VGA compatible controller: Neomagic Corporation NM2160 [MagicGraph 128XD] (rev 01)
    00:13.0 USB Controller: OPTi Inc. 82C861 (rev 10)
    00:14.0 IDE interface: OPTi Inc. 82C825 [Firebridge 2] (rev 30)
    Does this info help anybody to help me find out what the ** the sndconfig does to get sound to work ? I still don't have a clue what's missing in the current situation!!

  7. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It seems that you ESS card is a ISA card, which is harder to configure than a PCI one. Check your /proc/isapnp file to see if it's listed in there. If it's not listed there, you will need to know the base IO address, DMA channel and IRQ line in order to configure an ISA card.

  8. #8
    Just Joined!
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    20
    Hello, Dolda2000,

    The file /proc/isapnp ins't even there !
    Could this be caused by the fact I've built pnp into the kernel rather than a module? I don't know about isa to be honest..

    Also, sndconfig says it did not find a PnP or PCI card - I guess I should have paid more attention to that, but I didn't know it was telling me about the problem ...

    Anyway, when the soundblaster module is configured as follows, sound works (as long as I don't log out or something) :

    I/O Port: 0x220
    IRQ: 5
    DMA: 1

    Do I need the /proc/isapnp even though I know the values? I think those values may indeed be correct as it was found by sndconfig - at least, I hope they are.
    How can I (try to) get sound working using these values?

    Thanks very much,

    Joris

  9. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    If your sound card is hardcoded to use those values, you don't need to have /proc/isapnp. Otherwise you will. The fact that you don't is probably because you haven't built it into your kernel at all. Otherwise it would be there.

    Don't use sndconfig anymore, try this command instead:
    Code:
    modprobe sb io=0x220 dma=1 irq=5 ess=1869
    See if that works at all. It won't work if you reboot, but try if it works at all.

  10. #10
    Just Joined!
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    20
    Hello,

    I tried - but the modprobe doesn't work - should I comment out contents of /etc/modules or /etc/modules.conf or does this mean I should recompile ?

    Oh, where in the kernel config should I look to ensure ISA support is compiled ? I've checked with make xconfig, but both options under "Plug and Play configuration" are set to 'y' - is there another part of the kernel config which must be set ?

    Thanks, you've been very helpfull so far !

    Joris

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •