Find the answer to your Linux question:
Results 1 to 4 of 4
Hi forum folk I may have missed an important last step while trying to use modprobe to install a module and make it active. I could use some help here. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Location
    UK
    Posts
    33

    Help using modprobe to install a kernel module


    Hi forum folk

    I may have missed an important last step while trying to use modprobe to install a module and make it active. I could use some help here.

    The module is for a wlan driver, and appears to be available in the kernel. I found it using modprobe -l. the wanted module name is. r8192_pci. The other module already there r8169 is for the eth0, and works OK. I went ahead and used modprobe to install it, and lsmod to confirm they both are there..
    I don't know what the "mii" means, but it might be an important clue.
    Code:
    # modprobe r8192_pci
    #
    # lsmod | grep r81
    r8192_pci             252652  0
    r8169                  28925  0
    mii                     3210  1 r8169
    This is where it all goes wrong. wlan0 does not appear as a device. I check with inxi..
    Code:
    # inxi -N
    Network:   Card-1 Realtek RTL8191SEvB Wireless LAN Controller
               Card-2 Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver r8169
    Sure enough, Card #2 gets its module mentioned at the end of the line. Card #1 does not!

    Thanks for any help.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,558
    Well, you haven't provided enough information to help. How did you build it? What were the modprobe arguments that you used? What is the contents of the module configuration file? Stuff like that which we need to know in order to make some educated guesses as to your problem. Also, please provide distribution+version+kernel that you are using.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Location
    UK
    Posts
    33
    Quote Originally Posted by Rubberman View Post
    Well, you haven't provided enough information to help. How did you build it? What were the modprobe arguments that you used? What is the contents of the module configuration file? Stuff like that which we need to know in order to make some educated guesses as to your problem. Also, please provide distribution+version+kernel that you are using.
    Thanks for the reply rubberman.
    I did not have to build it. It was already present, available in the kernel. Although there is a driver package for Unix/Linux on the Realtek website, my Google searches indicated that this driver had been incorporated into the Linux kernel some time ago. I checked for what was available in the kernel with modprobe -l like this..
    Code:
    # modprobe -l | grep r81
    kernel/drivers/net/r8169.ko
    kernel/drivers/staging/rtl8192su/r8192s_usb.ko
    kernel/drivers/staging/rtl8192e/r8192_pci.ko
    kernel/ubuntu/rtl8192se/r8192se_pci.ko
    #
    I was pleased to see r8192se_pci was there. Next I used lsmod, which confirmed the r8169 module was installed, but not the WiFi one (r8192se_pci) as shown on the original posting. This is where I used modprobe to actually install the module, and then another lsmod to check the result.
    Code:
    # modprobe r8192_pci
    #
    # lsmod | grep r81
    r8192_pci             252652  0
    r8169                  28925  0
    mii                     3210  1 r8169
    #
    So far, so good, and I was expecting wlan0 to become available as a network device. I also knew that all this work would just evaporate at the next re-boot, so the modprobe instruction would have to be included in a startup file somewhere. The one I found was /etc/modules, which had clear instructions in the comments. I also discovered that some services will refuse to do their thing for devices that are mentioned in setup files that might have the last word. Just adding the module caused the other to be ignored. I had to add them both in, so they would be there after a re-boot.. like this..
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.
    # Parameters can be specified after the module name.

    loop
    r8192e_pci
    r8169
    I was not aware of any other arguments for modprobe that I would need beyond the module filename with the .ko extension removed, nor any mention of a configuration file with content devoted to just that module. If something like that is the missing part, then I may be stalled.

    The distribution is essentially Debian (Squeeze) from a Linux Mint LMDE install. This is a "rolling update-able" distro, and the kernel was 2.6.32-5-amd64 at the time. We then come to my, perhaps naive expectation that my actions would have been enough. I checked the network.
    Code:
    # iwconfig
    lo        no wireless extensions.
    
    eth1      no wireless extensions.
    
    pan0      no wireless extensions.
    #
    Finally, I used inxi (learned from Google)
    Code:
    # inxi -N
    Network:   Card-1 Realtek RTL8191SEvB Wireless LAN Controller
               Card-2 Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver r8169
    mint ~ # lsmod | grep r81
    r8192_pci             252652  0
    r8169                  28925  0
    mii                     3210  1 r8169
    #
    Notice the LAN controller has no driver - but I can see its in there. Hmm!

    While the mission example here is to get a WiFi network going, the main underlying task, and the question, is about getting right on how to invoke a module. This may not be quite the same thing as install a module from scratch.

    I thought it should not be so hard to get a WiFi working. I had to concede that re-installing Windows 7, for me, a retrograde step, did at least have it find the WiFi automatically, accept a WEP code, and be up and running in seconds.

    It still left the question of what major fumble did I make in trying to use a module?
    G

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,558
    Since it was already in the kernel build, you did not need to install it again, unless it was not in the default kernel configuration. At the least, you need to enable the wireless in your network manager, and then configure the device.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •