Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Hi Community, I recently realized that for what I'm using my media PC I don't need a fully loaded Win7 ultimate, office, picture mangemant, photoshop etc.... Most of the time ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2011
    Posts
    10

    Unhappy Unable to install any Linux distibution (Solved)


    Hi Community,

    I recently realized that for what I'm using my media PC I don't need a fully loaded Win7 ultimate, office, picture mangemant, photoshop etc....

    Most of the time I do Webbrowsing, music listening and video watching.

    That way I thougt, hey, give Linux a try, it's all free and there are pretty much no viruses to care about!

    After endless trys to install a distribution on my computer, I quit!

    I tried (all X86_64):
    - Ubuntu 11.06
    - Kubuntu 11.06
    - Fedora 15
    - Fedora 15 KDE
    - OpenSuse 11.4 Gnome
    - OpenSuse 11.4 KDE
    - Debian 11

    For each of these distributions, I made a live USB using Universal-USB-Installer-1.8.5.8.exe under Win7. Booting from the USB Flashdrive worked for each of them except Fedora 15 Gnome that booted but crashed continuously saying "hoops something has gone wrong. Please log in again".

    Every other distro crashed either during installation (always using GUI installation) or was so unstable after install that it's simply not usable.

    Here's my hardware setup:

    Zotac mini-itx socket LGA 1156 WiFi onboard
    4Gb DDR-3 1333 (2x2gb) Corsair XMS kit
    Intel Core-i5 650
    Asus USB3 PCI-E 1x extention card with NEC USB3.0 chip
    Maxtor DiamondMax Plus 9 160Gb Sata 1 HDD

    I have an Intel X25-M Postville 80Gb SSD for my Win7 setup but didn't try to install Linux on that one. However I tested Ubuntu 11.06 and OpenSuse 11.4 on a 2.5'' Sata 2 HDD from Hitashi. It was also unstable or didn't finish installation.

    I tested the memory (memtest 86+) and also both HDDs with HD Tune Pro. Both tests didn't reveal any errors. Hardware works perfectly.

    The only irregularity I found out was the +12V rail delivering only 8V to the motherboard. I saw that in AIDA64 under Win7. Nevertheless stresstesting the system under Win7 revealed it to be stable.

    I also tested a few of the Live-USBs on my ThinkPad T420s. They all worked on that despite it has brand new sandy bridge hardware instide.

    So can anyone tell me why every Linux installation I tried crashes or doesn't even finish installing before crashing?

    I'd love to test some other OS for personal experience, but I've no Linux knowledge at all, espetially when it comes to command lines.

    Thank you for your support.

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,482
    If would be helpful if you could post the actual error message that you get but, when this sort of thing happens, there are normally a few potential culprits:

    1. Graphics card not being configured correctly during install.
    2. Dodgy memory.
    3. Dodgy hard disk.
    4. Corrupt download / burn.

    Number 4 is probably the easiest to identify or rule out. For each of the iso images you downloaded, there will be a MD5SUM on the web site. Compare the official MD5 against one you generate for the .iso, if they are not identical then there is a corruption (or file change) issue and you will need to download again. While you are using USB, I'll include this for completeness. If your MD5SUMs match, you should burn the CD / DVD on to good quality media at the slowest speed your drive allows to avoid corruption during burn.

    Next easiest is number 3. Simply run a full scan from Windows before formatting the disk. If this is going to be a dual boot system (Win 7 and possibly Vista / Linux), then you may need to defrag and resize the Windows partition inside WIndows as it puts files in inconvenient places for partitioning.

    The dodgy memory is also easy (but time consuming) to check. Simply boot the live CD/DVD/USB and select the memtest option from the boot menu. If you can't see the menu then you should press Esc or Shift if that doesn't work. You should let memtest run for a few hours or preferably over night.

    The graphics card issue can often be side-stepped by using an alternate installersuch as the one provided by Ubuntu. Once the operating system is installed, you can then install the correct graphics drivers.

    It may also be worth trying Linux Mint. It's based off Ubuntu but has lots of extra goodies and pre-configuration completed.

    Hope this helps
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  3. #3
    Just Joined!
    Join Date
    Jul 2011
    Posts
    10
    Hi elija, thank you for the answere.

    I checked each MD5 and/or sha 256. They all match, no file changes between download and transfert to live-USB.

    I don't get what you mean by "While you are using USB, I'll include this for completeness".

    Dodgy hard disk and/or memory can be excluded. As I said, I tested the memory with memtest 86+ (3 passes, no error) and I low level-formated both HDDs I tested the installs on and did an error scan with HD Tune prior to installation. The hardware is OK.

    As for the graphics, how could an integrated Intel GMA from the core i5 not be installed properly?

    I cannot provide an error message. I don't know how to copy-paste it. Once the install crashed, the keyboard doesn't respond any more.

    However I can tell it's more random. I remember having read "kernel error" and "bad kernel". Also when OpenSuse loaded, there were some "FAiLED" in the checklist it displays while loading.

    Do you think burning a CD could do better than USB? The slowest my recorder can do is 4x on CD-R.
    By the way, I did an installation of Ubuntu 11.04 using the same live-usb that crashed on my PC on my old toshiba laptop that has a Core 2 Duo T7500, nVidia NVS 130, 2Gb ram and 250 Gb WD-Caviar blue HDD. It works flawlessly.


    Cheers

  4. #4
    Linux Engineer MASONTX's Avatar
    Join Date
    May 2010
    Location
    Mason Texas
    Posts
    934
    Try Ultimate, it is Ubuntu, but has a lot more drivers included in the DVD, so it may work better with your hardware.
    Registered Linux user #526930

  5. #5
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Is this a Laptop?
    I'm fairly certain you can get the machine to boot with the correct kernel boot option but then after you do that, your fans, USB ports or other things may stop working if this is a Laptop. I think you should try to add acpi=off to the end of the kernel line during boot up, I think this will allow you to boot. If you don't know how to do this, then just say so and we can show you.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #6
    Just Joined!
    Join Date
    Jul 2011
    Posts
    10
    Hi guys,

    @ Masontx

    I just tried Ultimate 2.9 x86-64. I checked MD5 after downlad, burned the ISO to a DVD with 2x (slowest possible) speed. Boot from CD and checked media integrity --> no errors.
    Booted onto the DVD and got the desktop. I was unable to connect to the wifi (Ubuntu 11.06 allowed me to do that at least). I lanched the installation process anyway --> crash after a few minutes after te file copy started. No error message, just a screen freeze.
    I tested the installation on both 3.5'' and 2.5'' HDD, twice the same.

    @ Mike Tbob

    Thanks for the advice, but I have no idea of how this could possibly work. I've never done command line.
    The computer is a homemade workstation --> mini-itx formfactor motherboard.

    I'm just gonna wait for further updates in linux distributions. I just don't have the currage right now to learn an other OS and get down to business with command lines.

    If you see any simple advice a total noob can put into action, it's welcome. But so fat, I quite, sorry.

    Best regards

  7. #7
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,482
    Just as a thought and a last ditch attempt What happens if you try to install a 32bit version on the troublesome computer? That bad kernel is nagging at me as I got something similar when attempting to install a 64 bit os on 32 bit machine.
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  8. #8
    Just Joined!
    Join Date
    Jul 2011
    Posts
    10
    Hi everyone,

    I did no other test yet, but I found an article on Phoronix were they review the ZaReason MediaBox 4220. Sorry can't provide the link as the forum software only allows link posting after reaching 15 posts or more. I'm only at 4 posts!

    They say their ZaReason MediaBox 4220 comes with a Zotac H55 mini ITX Wifi Motherboard. That's the same as I have. Their system has 2Gb RAM and a core i3. I've got 4Gb RAM and a core i5. The graphics core is the same thought.

    They state they installed Ubuntu 10.04 LTS 32bits without a problem on the shipped hitatchi HDD. So I'll try soonly a 32 bit version of linux and figure out if there's a clue.

    I'll keep you updated!

  9. #9
    Just Joined!
    Join Date
    Jul 2011
    Posts
    10
    Here I am again!

    I did a BIOS Update of my Zotac mobo, just in case. I performed it under Win7 using Zotacs GUI Tool. After reboot I got a BSOD telling me to check my hard drive. After searching the new BIOS I remembered that I had AHCI mode enabled before flashing. When I turned AHCI on again, I could boot my Win7 just fine.

    Now it turns out that AHCI basically allows NCQ and HotPlug for Sata devices. For a reason I ignore, that was the option that made each and every Linux distribution I tried to be unstable.

    I'm writing this post while under Ubuntu 11.04 x86_64!! Finally!!

    I just turned the Sata controller to normal IDE mode rather than AHCI and everything goes well.

    Does this significate that both the Maxtor DiamondMax plus 9 and the 2.5'' Hitashi I tested don't support NCQ and that by having AHCI enabled it caused trouble in the the Linux kernel?

    Also, could I turn AHCI on again and install Linux an my X25-M Postwil SSD which obviously supports NCQ?

    Thank you for inputs and advices.

  10. #10
    Just Joined!
    Join Date
    Jul 2011
    Posts
    10

    [SOLVED] Unable to install any Linux distibution

    I mark this thread as solved as it was really the AHCI mode from the BIOS that was conflicted with an old HDD that doesn't support NCQ.

    Since I got my linux on a newer HDD with NCQ I can enable AHCI and boot Win7 along with Linux.

    Cheers!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •