Find the answer to your Linux question:
Results 1 to 4 of 4
Hello On a test host that has two partitions (one to hold the OS, the second to hold images made with Clonezilla), partition #1 used to start at sector 63. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2007
    Posts
    127

    Question Why does fdisk create partition at 2048 instead of 63?


    Hello

    On a test host that has two partitions (one to hold the OS, the second to hold images made with Clonezilla), partition #1 used to start at sector 63.

    I had an issue booting with Windows7, so I deleted partition #1. But now, when I run fdisk to recreate the partition, fdisk won't let me choose 63 as the start sector but instead use 2048... which is too small and Clonezilla refuses to restore a new image.

    Does someone know what could explain this change, and how to solve this issue?

    Before, when cloning Windows7
    Code:
    Model: ATA WDC WD3200BEVT-2 (scsi)
    Disk /dev/sda: 625142448s
    Sector size (logical/physical): 512B/512B
    Partition Table: msdos
    
    Number  Start       End         Size        Type     File system  Flags
     1      63s         537358184s  537358122s  primary  ntfs         boot
     3      537358336s  625141759s  87783424s   primary  ext2
    Now
    Code:
    Disk /dev/sda: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xf1f75308
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1            2048   537358335   268678144    7  HPFS/NTFS/exFAT
    /dev/sda2       537358336   625141759    43891712   83  Linux
    Thank you.

  2. #2
    Linux Newbie
    Join Date
    Nov 2007
    Posts
    127
    No idea why fdisk did this, but removing all partitions and starting from scratch solved the issue.

  3. #3
    Just Joined!
    Join Date
    Apr 2012
    Posts
    1
    Quote Originally Posted by littlebigman View Post
    No idea why fdisk did this, but removing all partitions and starting from scratch solved the issue.
    For anyone else facing this issue, I wanted to recommend GNU parted. It is a command-line utility that will allow you to select any start value for your partition. In performing this operation, I wiped the MBR of my disk first (using dd), to avoid warning messages from parted about damaging the old filesystem(which I wanted to erase anyway).

    If you want to preserve data on the existing filesystem, don't do this.

    You may need to read the built-in help, and then by setting the units to sectors, you can match your previous start sector for the disk by typing:
    Code:
    (parted) mkpart
    partition type? primary/extended? p
    file system type? [ext2] ntfs (this will merely set the partition ID)
    start? 63s ("s" means sector in parted)
    end? 537358184s
    There are reasons why the newer linux fdisk defaults to starting at 2048, and I suggest the reader find out about these (ie a software standard of dividing partitions on a 1MByte boundary, and also the arrival of some new drives with 4k sectors).

    Even better for ext2 filesystems, this will make a partition fill the entire disk:
    Code:
    (parted) mkpart
    partition type? primary/extended? p
    file system type? [ext2] *hit enter* (this will merely set the partition ID)
    start? 1s ("s" means sector in parted)
    end? -1s (In parted, negative 1 means the very last sector)
    (why waste unallocated sectors if you don't need compatibility with other OS?)
    Last edited by user503629; 04-09-2012 at 11:50 PM.

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hi, user503629!
    Great advice given there! Very similar to what I have told folks in the past.
    The OP, however, hasn't been active since shortly after posting this question.
    So I'll lock this down for now.

    But please feel free to help out on any other threads that catxh your eye!
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •