Find the answer to your Linux question:
Results 1 to 8 of 8
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    having trouble with ibus

    OK, I'm really having trouble with ibus now
    I had ibus and ibus-pinyin installed in my system to input Chinese
    But since my system update today, ibus was upgraded from 1.3.9 to 1.4.0
    I can no longer select Chinese input method with it

    I've been searching for the solution for the rest of the day, and nothing valuable was found
    Please help me~

  2. #2
    I'm using Arch Linux, Here's the system info and ibus version

    [jpli@balance ~]$ uname -a
    Linux balance 3.0-ARCH #1 SMP PREEMPT Tue Aug 30 08:53:25 CEST 2011 x86_64 AMD
    Phenom(tm) 9150e Quad-Core Processor AuthenticAMD GNU/Linux

    [jpli@balance ~]$ pacman -Qs ibus
    local/ibus 1.4.0-1
    Next Generation Input Bus for Linux.
    local/ibus-pinyin 1.3.11-2
    The PinYin Engine for IBus Input Framework.
    local/ibus-sunpinyin 2.0.3-1
    The SunPinYin Engine for IBus Input Framework. SunPinYin is a Statistical
    Language Model based pinyin IME by Sun.

    And the desktop environment input method settings:

    [jpli@balance ~]$ env | grep IM

    desktop environment startup code:

    [jpli@balance ~]$ tail ~/.xinitrc

    export GTK_IM_MODULE_FILE=/etc/gtk-2.0/gtk.immodules
    ibus-daemon --xim -d
    #ibus-daemon -d # This option does not work with libreoffice

    # exec gnome-session
    # exec startkde
    # exec startxfce4
    # ...or the Window Manager of your choice
    exec ck-launch-session fvwm

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Not being familiar with this application, have you tried to uninstall and then reinstall the packages from scratch?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
  5. #4
    Quote Originally Posted by Rubberman View Post
    Not being familiar with this application, have you tried to uninstall and then reinstall the packages from scratch?
    Thanks, I'll try if all other attempts fail

  6. #5
    To the administrator:
    Thanks a lot for rename my post, must have caused you some trouble, won't do this again

  7. #6
    try fcitx input method~~

  8. #7
    Quote Originally Posted by skyhacker View Post
    try fcitx input method~~
    I'm already using fcitx, thank you

    I got this link from Arch Linux Forum, suggesting I rebuiding ibus-pinyin engine, it's worth trying

  9. #8
    you are welcome

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts