Find the answer to your Linux question:
Results 1 to 8 of 8
Today I decided to try out Linux, so I downloaded Arch, since it was small and a fast download. I did the stuff that is listed below, but first, my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2011
    Posts
    5

    Made a Mistake With Partitions, Have I Lost Everything?


    Today I decided to try out Linux, so I downloaded Arch, since it was small and a fast download.

    I did the stuff that is listed below, but first, my issue and a yes or no question:
    If I boot windows, without the Linux CD in, it shows me the "Windows Error Recovery" if I hit start windows normally, it starts loading the windows 7 screen, half way through the Windows Logo, it freezes, then brings me back to the windows error recovery, so I tried "Launch startup repair" it then brought me to a "Windows boot manager" and says 1. Insert your windows installation disc and restart, 2 choose your language settings and then click "next" 3 click repair computer.

    Status: 0xc000225

    Info: The boot selection failed because a required device is inaccessible.

    My question is, is there any way to fix this without the disc? I don't own the actual disc, only the key that came with the computer, also my bandwidth slow and the cap is low, which makes downloading it off a different computer nearly impossible.

    If it is possible, I have provided information on what I did, to help make assistance easier.

    If it isn't possible, can you please just inform me that and I'll have to figure something out, but this would definitely be difficult. Also, would I still be able to get my information back? (I'd be grateful if you even just told me whether I could get my stuff back or not.)



    What I did:
    I placed it on a CD and rebooted, started going through the install. First thing I did was type /arch/setup then I got up to a list of different things:

    1 Select source
    2 Set editor
    3 Set clock
    4 Prepare Hard Drive
    and it continued to 9.

    I clicked prepare hard drive(s) and gave me options to auto prepare, manually partition, manually configure, rollback or return to main menu. I selected manually partition hard drive, as I already had a 13GB partition ready for Linux. It asked me which disk to partition, "/dev/sda" or other. Since the /dev/sda said 232GB beside it, I figured that was my partition with Windows 7 and all my other data, so I chose other, so I could find the smaller partition. It asked for the full path of the device to partition, I just clicked OK, which lead me to /dec/sda.

    Here's where I am pretty sure I screwed up, it listed 4 things, sda1 ,sda2, sda3, sda4. 1 was 1.05MB, so I figured I'd leave that alone, 2 was labeled system, so I didn't touch that, 3 was my 236GB partition, so I moved on and 4 was labeled new volume, and was 13GB, so I decided to try and work with that, so I hit the down arrow to sda3 and hit enter, I noticed nothing, I hit it a few more times, then moved over to "write" at the bottom, hit that, it gave me some sort of error message, I then realized I had to go back to class, so I shut it down through the power button and put it away. (laptop)

    Thank you for reading this large wall of text and I hope you can provide something to help.

    Alternatively, if you found an article on the internet that directly relates to my situation, a link would be nice, but I don't want to do anything unless I know someone believes that it would work in my specific condition to keep the highest change possible of data recovery.

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    The sda refers to the actual physical hard drive. The sda1, 2, 3 and 4 refer to the partitions on the hard drive.

    Do you have only one hard drive?
    Is it a 232GB (approximately) hard drive?

    Your quote below, was that sda or sda1, sda2, etc.???

    Since the /dev/sda said 232GB beside it
    If you had created a partition from windows for your Arch install of 13GB and sda4 was 13GB, that was probably the correct partition to use. You should have been able to select to format it in a Linux filesystem format.

    so I hit the down arrow to sda3 and hit enter,
    Is that a typo? did you mean you moved the arrow down to sda4 which you said was the 13GB? I've not done an Arch install and this sounds a little different than a normal Linux installation.

    If your problem is that you are no longer able to boot windows 7, you will have a difficult time without an actual installation disc. From what I understand, the Recovery discs do not have the files/programs necessary to do that.

    You could try downloading TestDisk or SystemRescueCD to try to save your data or download SuperGrubDisk which might be able to repair your bootloader if you have access to another computer.

  3. #3
    Just Joined!
    Join Date
    Oct 2011
    Posts
    5
    The drive is 250GB, ~232GB for the partition C:\ which has/had my windows and files, then my other partition I was going to use for Linux, a "systems" partition and some other partition. The systems partition came from the files originally on it when I got it. It's a Compaq so it has the HP stuff. And yes, I hit sda4 rather than 3, that was a typo, I am sure I did hit sda4.

    I was luckily able to find a friend who has a Windows 7 disc, but when I tried to use it, it gives me the same error, telling me to use the disc(which is in) also when I first turn it on, after the initial screen that's orange(Compaq's screen thing) then it goes black, the CD drive starts reading, then it gives that error.

    I don't understand why it boots off of Arch but not Windows 7. Will I have to some how format it with Arch then install Windows 7 afterwards and lose all my files?

    Also, should I post in the Arch forums and link to here to get some Arch support? I wasn't sure where to place this issue since it's kind of Arch, kind of general, kind of windows, and I am a newbie.

    And if I was to get Arch installed, would I be able to check if my files are still there, maybe back them up?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I don't understand why it boots off of Arch but not Windows 7
    Are you referring to booting the Arch CD? I thought from your first post you could not install Arch.

    but when I tried to use it, it gives me the same error, telling me to use the disc(which is in)
    Do you have more than one CD/DVD physical drive? I doubt it's looking on the wrong drive but?? I believe Compaq is owned by HP but I've never used a Compaq. I bought a computer from HP with windows 7 pre-installed. It had three partitions, 100MB boot partition, a 12GB HP recovery partition and the rest windows system files.

    First of all, are you using the Arch disk? Can you boot with it? Did you get it installed? If you are using a Live CD of Arch, boot it and look for a terminal. You should have some tabs or a menu somewhere. I've never used Arch so am not familiar with it. When you find it, enter this command:

    fdisk -l
    That's a Lower case Letter L in the command. You may need to log in as root before running the command so type su, hit the enter key and then the command. This will show you the drive/partition information for your drive which would be useful for someone here to help. You might take a look at the Arch wiki or forums if available. I'm not really familiar with it.

  6. #5
    Just Joined!
    Join Date
    Dec 2007
    Posts
    35
    HI,

    With a laptop, I never dual-boot Linux on the same hard drive as Windows. This way, Windows doesn't get damaged. What I do is to install Linux on an EXTERNAL USB hard drive. I make sure that the boot-loader (Grub), gets installed on the Linux disk, and NOT on the Windows disk. Grub will find your Windows, and put it on it's boot list.

    When you boot-up your machine, the Grub menu will offer you the choice of either Windows, or Linux. If you unplug the USB hard drive, then Windows will boot up normally as if you never had run a Linux OS before.

    Doing it this way, makes it an easy recovery, if you should make mistakes when installing a Linux. In the future, if you get tired of the OS you currently use, just re-format your external hard-drive, and install your next version of Linux, or BSD, or whatever may be your choice. Or you can attempt to dual boot another Linux version with your existing OS, on your USB hard drive. Just make Grub aware of the new OS you just installed. And if you've accomplished all this, on a separate hard drive, You'll never have to worry about damaging Windows in the process.

    By-the-way, this process on a separate hard drive mentioned above, can also be done on a USB memory stick. Just put the memory stick in your pocket when you are finished. Should you use a memory stick, just make sure that you select one that's large enough with wiggle room, so your OS can function normally, for daily usage.

    Hope this helps. As far as your current predicament, it seems that you need to re-install Windows, before you try my above suggestions.

    Cheers!

  7. #6
    Linux User
    Join Date
    Nov 2008
    Location
    Tokyo, Japan
    Posts
    260
    The answer to your Yes/No question should be "No" you haven't lost everything, at least not from what I can tell in your description. You didn't change the sizes of any partitions, right? So all of your data should still be intact.

    Probably what happened is this: when you executed the "write" command in the Arch Linux disk utility program, it probably modified the Master Boot Record (MBR) of the disk. I am not a Windows expert, so I don't know for sure, but it is entirely possible that Windows 7 does a checksum of the MBR and alerts the operating system if the checksum changes. This is to protect against boot sector viruses. When a non-Windows program (such as a virus, or a Linux installer) modifies the MBR, this changes the MBR checksum value and triggers the failsafe in Windows 7.

    If you didn't do anything else to resize the partitions, and you did not execute any formatting commands (and as far as I understand, you did neither of those things), then the ordinary Windows 7 recovery disk should put everything back to normal, and you will not have lost any data..

  8. #7
    Guest
    Join Date
    Feb 2005
    Posts
    312
    It's hard to know what you've done... I'd hazard a guess that you've wiped an entire extended partition or overwritten the MSDOS partition table...

    The said partition table is usually kind of like this:

    Primary partition (usually the "C drive")
    Secondary partition:
    Logical drive in the secondary partition ( e.g. "D drive")
    Logical drive in the secondary partition ( e.g. "E drive")
    Logical drive in the secondary partition ( e.g. "F drive")

    The problem arises that if you remove e.g. the "D drive" in an MSDOS partition from a program like parted or gparted, you can actually be removing the E and F drives as well... I found this out once the hard way once... I'm still not sure how I did it, but it happened.

    Without fdisk layout of your partitions, before and after, it's impossible to tell. You could boot from a livecd, chroot into the system and try to repair the partition table using testdisk. Also you should be able to boot from the recovery cd and restore the mbr, but that probably won't make any difference.

    Most likely your best option is to cut your losses, get your data backed up and reinstall.

    Also: Arch is not really for beginners, though installing any GNU/Linux distro requires some basic knowledge of partitioning a disk and installing an OS. Ubuntu is pushed as a beginners distro, you might find it more suitable - though if you don't know what you're doing you can still make a mess of partitioning and lose all of your data... Ubuntu is also a livecd so you can try it without actually installing it.

  9. #8
    Just Joined!
    Join Date
    Oct 2011
    Posts
    5
    I figured I'd be fine since I've installed XP a million different times, whether it be dual boot, install on a completely formatted hard drive or formatting and then installing, but this way way out of my league.

    It had tons of stuff I've never seen before, which I didn't expect. I gave up the hunt to recover data, and I have Ubuntu installed, that was easy.

    Waiting for Windows 7, it's in the mail, I must say, I really do like Linux, however confusing it may be.

    I learned something so many people I've talked to have learned before, which is the hard way. Oh well, lost some data, gained some knowledge, fair trade.

    Thanks for the replies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •