Find the answer to your Linux question:
Results 1 to 2 of 2
Hi All, I was setting up VNC server for RHEL 5.5 and ran into an "interesting" outcome. I'm not sure if this is expected: Now, all works as expected *if* ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2010
    Posts
    11

    VNC Server: Running as Root Vs User


    Hi All,

    I was setting up VNC server for RHEL 5.5 and ran into an "interesting" outcome. I'm not sure if this is expected:

    Now, all works as expected *if* I run vncserver as one of the users:

    Code:
    <user1># vncserver
    When I run nestat -an | grep 5801 I see:
    Code:
    tcp        0      0 0.0.0.0:5801              0.0.0.0:*                   LIST
    OK, all good. Now, if I want to run vncserver as root to run connections for all users, vnc will start a separate connection for each, however I see this in netstat:

    Code:
    <root># /sbin/service vncserver start
    Code:
    tcp        0      0 127.0.0.1:5801              0.0.0.0:*                   LIST
    tcp        0      0 127.0.0.1:5802              0.0.0.0:*                   LIST
    tcp        0      0 127.0.0.1:5803              0.0.0.0:*                   LIST
    Now, I can connect via an ssh tunnel, however I am wondering why I cannot simply connect over http? It seems to revolve around VNC running on 0.0.0.0 as the user and 127.0.0.1 as root. I checked through the VNC config files, but I do not see anything that specifies to run it one way as a user and another way as root.

    Help!

  2. #2
    Just Joined!
    Join Date
    Jun 2010
    Posts
    11
    Found my issue!

    I had the /etc/sysconfig/vncserver file set with the "-localhost" option for VNCSERVERARGS. After I removed that, I have a full http connection on each server.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •