Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, I am having an issue similar to this. I would like some help if possible. Everything was working fine untill I ran this Code: sudo aptitude install lsb after ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    7

    not able to run startx


    Hi,

    I am having an issue similar to this. I would like some help if possible. Everything was working fine untill I ran this
    Code:
    sudo aptitude install lsb
    after that My computer kept on getting stuck and wasn't able to run startx.
    when startx was ran it would give me this error.
    Code:
    Fatal server error:
    Server is already active for display 0
            If this server is no longer running, remove /tmp/.X0-lock
            and start again.
    
    
    Please consult the The X.Org Foundation support
             at wiki.x.org
     for help.
    
     ddxSigGiveUp: Closing log
    I ran lspci | grep -i vga and got
    Code:
    00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
    and grep -i driver /etc/X11/xorg.conf and got
    Code:
    Driver          "fbdev"
    Thank you for your time and help.

  2. #2
    Just Joined!
    Join Date
    Sep 2005
    Location
    Edmonton, Canada
    Posts
    48
    I don't know if installing 'lsb' caused it, or something else, but X Windows is running on your system. The first error message says so: "Server is already active for display 0".

    However:
    The 'fbdev' driver in your xorg.conf file is a special video driver that runs X-Windows in a system memory frame buffer that emulates a gerneric video card, but it is not really displayed, because it's not a real video card and has no physical connectors. Normally the fbdev is used to run X-Windows on a headless (and, if desired, videocard-less) computer for the purpose of running programs that require the $DISPLAY var to be valid. The fbdev can be viewed by a vnc client if a vnc server is started on fbdev's display.

    Since lspci reveals an Intel video card, try changing the 'fbdev' keyword in xorg.conf to 'intel', and reboot.

  3. #3
    Just Joined!
    Join Date
    Aug 2012
    Posts
    7
    I tried changing it and still stuck at boot screen. I did alt f4, i logged in and after that I ran startx. Now the screen is stuck at root@server:# no keys can be pressed or anything.

  4. #4
    Just Joined!
    Join Date
    Oct 2008
    Posts
    7
    Could you give us a little more background of your system such as your video card and a copy of your xorg.conf file?

  5. #5
    Just Joined!
    Join Date
    Aug 2012
    Posts
    7
    Code:
    root@server:~# cat /etc/X11/xorg.conf
    Section "Device"
            Identifier      "Configured Video Device"
            Driver          "intel"
    EndSection
    
    Section "Monitor"
            Identifier      "Configured Monitor"
    EndSection
    
    Section "Screen"
            Identifier      "Default Screen"
            Monitor         "Configured Monitor"
            Device          "Configured Video Device"
    EndSection
    I am running this on a Dell B110 with an Integrated Intel Extreme Graphics 2.

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    What happened when you followed the advice in the error message to remove the remove /tmp/.X0-lock file?

  7. #7
    Just Joined!
    Join Date
    Aug 2012
    Posts
    7
    I get the following error.

    Code:
    root@server:/tmp# rm /tmp/.X0-lock
    root@server:/tmp# startx
    
    _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
    _XSERVTransMakeAllCOTSServerListeners: server already running
    
    Fatal server error:
    Cannot establish any listening sockets - Make sure an X server isn't already running
    
    Please consult the The X.Org Foundation support
             at wiki.x.org
     for help.
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    
     ddxSigGiveUp: Closing log
    Server terminated with error (1). Closing log file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •