Find the answer to your Linux question:
Results 1 to 4 of 4
Hi! I made a directory and gave it a 777 mod (owner and group is root). when mounting an external cifs folder (windows share), the mod and permissions changed, what ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    1
    1 is offline
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    mount change folder directory


    Hi!

    I made a directory and gave it a 777 mod (owner and group is root).

    when mounting an external cifs folder (windows share), the mod and permissions changed, what cause the folder to be unwriteable for some reason and when trying to write to it, I get the error message "no space left on device" (although I tried using the root user).

    ls -l before mounting:
    drwxrwxrwx 3 root root 4096 Nov 1 11:05 foldername

    ls -l after mounting:
    drwxr-xr-x 1 differentuser root 0 Jul 5 09:05 foldername


    I'm mounting the folder with fstab, and didn't changed anything in the past few weeks. Everything worked fine until yesterday.



    Any suggestions what went wrong and how come it changed ?



    Many thanks!

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hello and welcome!

    Leaving off the permissions part for a moment, have you checked that the Windows machine's disk which contains the share is not, in fact, full and has no space?

  3. #3
    1
    1 is offline
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    Thanks
    The problem was the windows shared folder, although permissions, quota and free space looked good and worked well for months, removing the folder and re-creating it with the same configurations did the trick.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hey, as long as you got it sorted!

    Will mark as Solved for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •