Find the answer to your Linux question:
Results 1 to 2 of 2
I have just started trying Ubuntu 12.10 through VM Ware Player 5.0.1, and every time I boot, it gives me the sames message: "The default sound device cannot be opened: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Location
    New South Whales, Australia
    Posts
    31

    No sound on Ubuntu through VMware


    I have just started trying Ubuntu 12.10 through VM Ware Player 5.0.1, and every time I boot, it gives me the sames message:

    "The default sound device cannot be opened: A deviceID has been used that is out of range for your system. Sound will be disconnected."

    I have tried the solution of adding these lines to the virtual machines VMXF file, as it doesn't have a VMX file:

    sound.present = "TRUE"
    sound.virtualDev = "es1371"
    sound.filename = "-1"
    sound.autodetect = "TRUE"

    But still no luck. Has anyone had similar experiences?

    Any advice would be greatly appreciated

  2. #2
    Just Joined!
    Join Date
    Feb 2013
    Posts
    1
    I was getting the same error message when running Fedora 18 in VMware Player 5.0.1 and I fixed it with a couple of configureation changes in Fedora.

    In recent distributions of linux sound has been handled by PulseAudio. In the past, I have had much better luck with Alsa. However, I had found a fix that worked for pulseaudio in "real" installations and decided to try it in "virtual."

    1) (in the guest host) modify /etc/asound.conf to contain only these lines:

    pcm.pulse { type pulse }
    ctl.pulse { type pulse }
    pcm.!default { type pulse }
    ctl.!default { type pulse }

    [ I may have rebooted the guest host and or the virtual machine at this point ]

    2) reconnect the "virtual" sound card

    right click on the speaker icon to the right of the VMware toolbar

    3) from within (the guest host) linux (in my case Fedora) select the appropriate sound configuration hardware profile:

    in my case since, I just had stero speakers, I chose "Analog Stero Output"

    Hope this helps you and others.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •