Find the answer to your Linux question:
Results 1 to 3 of 3
So i have been trying to get mint 14 32 bit to run nice on my desktop all freaking day now. im stuck trying to get my video drivers installed. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    10

    need help with nvidia drivers. Struggling with the basics maybe???


    So i have been trying to get mint 14 32 bit to run nice on my desktop all freaking day now. im stuck trying to get my video drivers installed. i have a geforece fx 5700 ultra she is old it know.

    went to geforce.com/drivers/results/35482 and found my card listed in devices supported by this driver. on the very very bottom of the web site it gives instruction on how to run it. so i did this is what they say "Installation instructions: Once you have downloaded the driver, type " " to install the driver. NVIDIA now provides a utility to assist you with configuration of your X server configuration file. See the README or run 'man nvidia-xconfig' for details on usage and instructions for those wishing to edit their X config file by hand."

    I ran the "sh NVIDIA-Linux-x86-173.14.31.pkg1.run" and gives me this "you appear to be running an x server, please exit x before installing. for more infomation go to nvidia.com"

    im stuck here at the "x server configuration file" part. I don't know how to use it????? the instructions say to write. "man nvidia-xconfig" but i get nothing.
    it also says that i can do it manualy and i found instructions to do that. to do this it says to go to /etc/X11/xorg.conf

    so i type
    "cd ../etc" then press enter
    "cd ../X11" press enter
    "xorg.conf" press enter

    and nothing happens, am i doing it wrong?









    Im just stuck here can someone please help me out before i pull my hair out.

    thanks for helping me in advance
    Last edited by glutetoot; 03-23-2013 at 05:29 PM.

  2. #2
    Just Joined!
    Join Date
    Jan 2013
    Posts
    10
    so here are the intructions im trying to do now come driectly from nvidia.com

    Manually Editing the Configuration File


    In April 2004 the X.Org Foundation released an X server based on the XFree86 server. While your release may use the X.Org X server, rather than XFree86, the differences between the two should have no impact on NVIDIA Linux users with two exceptions:

    The X.Org configuration file is /etc/X11/xorg.conf while the XFree86 configuration file is /etc/X11/XF86Config. The files use the same syntax. This document refers to both files as “the X config file”.

    The X.Org log file is /var/log/Xorg.#.log while the XFree86 log file is /var/log/XFree86.#.log (where # is the server number -- usually 0). The format of the log files is nearly identical. This document refers to both files as “the X log file”.

    In order for any changes to be read into the X server, you must edit the file used by the server. While it is not unreasonable to simply edit both files, it is easy to determine the correct file by searching for the line

    (==) Using config file:

    in the X log file. This line indicates the name of the X config file in use.

    If you do not have a working X config file, there are a few different ways to obtain one. A sample config file is included both with the XFree86 distribution and with the NVIDIA driver package (at /usr/share/doc/NVIDIA_GLX-1.0/). Tools for generating a config file (such as xf86config) are generally included with Linux. Additional information on the X config syntax can be found in the XF86Config manual page (man XF86Config or man xorg.conf).

    If you have a working X config file for a different driver (such as the “nv” or “vesa” driver), then simply edit the file as follows.

    Remove the line:

    Driver "nv"
    (or Driver "vesa")
    (or Driver "fbdev")

    and replace it with the line:

    Driver "nvidia"

    Remove the following lines:

    Load "dri"
    Load "GLCore"

    In the Module section of the file, add the line (if it does not already exist):

    Load "glx"

    If the X config file does not have a Module section, you can safely skip the last step if the X server installed on your system is an X.Org X server or an XFree86 X release version 4.4.0 or greater. If you are using an older XFree86 X server, add the following to your X config file:

    Section "Module"
    Load "extmod"
    Load "dbe"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection

    There are numerous options that may be added to the X config file to tune the NVIDIA X driver. See Appendix B, X Config Options for a complete list of these options.

    Once you have completed these edits to the X config file, you may restart X and begin using the accelerated OpenGL libraries. After restarting X, any OpenGL application should automatically use the new NVIDIA libraries. (NOTE: If you encounter any problems, see Chapter 8, Common Problems for common problem diagnoses.)






    I have tried for hours to do this manually to no avail. i can visually see the file /etc/X11/xorg.conf in the command terminal, but can not seeam to get into it to change it.



    Can some one tell me, in different, words exactly what to put into the terminal for the proper commands???? maybe step by step? meanby im enterening the wrong commands!!????

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    10
    ok no i have entered "pico Xorg.#.log" enter
    and was able to searh for"(==) Using config file:" and found it to be using /etc/X11/xorg.conf

    now what i still cant figure out how to change the /xorg.conf file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •