Find the answer to your Linux question:
Results 1 to 8 of 8
Hello! I have a quite old laptop, with an Intel integrated gfx card, 965 Express Chipset Family, X3100. Currently I have a USB key and a few linux distros (Crunchbang ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2013
    Posts
    4

    Question Cannot change resolution above default. Intel 965 Express, X3100


    Hello!

    I have a quite old laptop, with an Intel integrated gfx card, 965 Express Chipset Family, X3100.

    Currently I have a USB key and a few linux distros (Crunchbang 11, Fuduntu 2013.1, Mint 14, Manjaro, Snowlinux 4 and Fedora 1 to try, but whenever I boot in Live mode (with any of them), it doesnt allow me to set it to my full resolution, 1280x800, only 1024x768 or lower.

    After searching, linux should be ready out-of-the-box for this old thing. Shouldn't it?
    As far as I've read and searched myself, it doesnt create a xorg.conf where I could change something..or maybe I just cant find it.

    Also, I have another laptop (about the same age) and it has a VIA or something integrated graphics, and it works perfectly in Live-mode.

    I have used UNetBootin and LinuxLive USB creator (LiLi), both have the same result.

    And what I noticed when trying Snowlinux - the part when loading (blue and white bar at the bottom) is in the full resolution, but at the end of loading it sets it to a lower resolution.

    How can this be fixed (set the OS display resolution to 1280x800)?

  2. #2
    Just Joined!
    Join Date
    Dec 2012
    Posts
    30
    Boot into any of the Linux flavors, and run the xrandr command. That lists the available screen resolutions that Linux can see. The entry with a '+' after it is the preferred mode, and a '*' after it shows the current mode. The xrandr command can also be used to set a specific resolution.

  3. #3
    Just Joined!
    Join Date
    Dec 2012
    Posts
    30
    So if the xrandr command lists 1280x800 as an available resolution, set that resolution with this command:

    Code:
    xrandr -s 1280x800

  4. #4
    Just Joined!
    Join Date
    Apr 2013
    Posts
    4
    It doesn't show any other resolutions, just the default ones (1024x768, 800x600..).

  5. #5
    Just Joined!
    Join Date
    Dec 2012
    Posts
    30
    Perhaps the Intel driver will fix that problem.

  6. #6
    Just Joined!
    Join Date
    Apr 2013
    Posts
    4
    Ok, so I managed to install Fedora on my USB stick. Still not recognizing 1280x800.

    I installed the drivers, didn't help. I tried to add a new mode to xrandr through Terminal, does not work. Also, I generated a new xorg.conf file, but I don't know what is what in there, what would I need to change to get my resolution.

    Any other suggestions that I might try?

    Oh, and the resolution on Grub is as needed - 1280x800, so it's a problem in Fedora (and other Linux distros).

  7. #7

  8. #8
    Just Joined!
    Join Date
    Apr 2013
    Posts
    4
    I tried setting a new Resolution from the ThomasMcA link, added it to VGA1 (it put it there automatically, so I just went with it), it sort of changed the resolution, I could notice it, but there still is a black bar on the right side and the bottom is messed up aswell.

    Picture:
    IMG_20130414_132334.jpg
    Last edited by DustyLv; 04-14-2013 at 10:30 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •