Find the answer to your Linux question:
Results 1 to 7 of 7
So I started poking around my Samsung Chromebook in Developer mode and figured out how to do some basic (read: navigation) stuff. I know next to nothing about Linux, but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2013
    Posts
    4

    Chrome OS is locking me out of root.


    So I started poking around my Samsung Chromebook in Developer mode and figured out how to do some basic (read: navigation) stuff. I know next to nothing about Linux, but I did manage to set a password for the default user (chronos). I figured it'd be a good idea since it has sudo power, but now I can't get in as root for whatever reason. I don't recall it asking for a password before I set the one for chronos, but the one I set doesn't work and with my luck I accidentally set an arbitrary one. If there is a default password or something that I somehow bypassed, does anyone know what it might be? Or if there's something blatantly obvious I'm doing wrong, like using the localhost name root?

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hello and welcome!

    so does sudo still work for user chronos? if so, then try:

    Code:
    sudo passwd
    you should be prompted (twice) to enter a new root password.

  3. #3
    Just Joined!
    Join Date
    Apr 2013
    Posts
    4
    Thank you!

    I tried what you said (from the root directory, as chronos if that matters) and it told me "Authentication token lock busy, password unchanged". What does that mean/how do I fix it?

    I do recall screwing something up at about 2:30 last night when playing around in the root directory. I tried the command:
    Code:
    view tmp
    thinking I'd see my temp files, instead it completely freaked out and I had a screen full of empty lines, save for a hyphen at the far left of each. Nothing I tried was responding, I just kinda tried random things till it went away. I'm guessing I screwed something up royally when that happened, because that's all I can think of that I did horribly wrong.

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    is the root (/) partition mounted read-only? try this first:

    Code:
    sudo mount -o remount,rw /

  5. #5
    Just Joined!
    Join Date
    Apr 2013
    Posts
    4
    It says that it's "write protected" when I try that.

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by Tqwen View Post
    It says that it's "write protected" when I try that.
    That sounds like Google hardware/firmware to me. Perhaps it needs to be rescued (Samsung alternative). Hopefully it doesn't come to that, but I'm not sure what else to suggest to you.

  7. #7
    Just Joined!
    Join Date
    Apr 2013
    Posts
    4
    The weird part is that I have gotten in as root before. It didn't ask for a password, but then that mess with tmp happened. Might not have been that, but I do know that that was my only horrible error.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •