Find the answer to your Linux question:
Results 1 to 8 of 8
hi i have solved my previos prblem of grub being corupted by vista by installing grub and linux on my extra internal hard drive i wan to boot into grub ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2013
    Posts
    14

    seting ubuntu to boot first


    hi i have solved my previos prblem of grub being corupted by vista by installing grub and linux on my extra internal hard drive i wan to boot into grub because i have a winloader in it but i cant seem to get drive 2 to boot first i have to do the whole f12 thing i changed boot order in bios but that did nothing win booted like nothing happended so i need some help
    thanks
    dc

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,107
    It's difficult to understand your problem due to your lack of punctuation, misspellings and one long run on sentence. I am guessing you have two hard drives with the internal containing windows and the external containing Ubuntu and that you have installed Grub on the external to the mbr, is that correct? If you set the external to first boot priority and it still booted the internal drive then it's either a system board/BIOS problem or a user error. Check out all the options in the BIOS. What computer manufacturer, system board do you have?

  3. #3
    Just Joined!
    Join Date
    Apr 2013
    Posts
    14
    Sorry for the poor grammer. It is a internal drive not ext . Vista is on drive 0 and ubuntu is on drive 1. The box is a dell t3400 . I changed the boot order in bios to boot drive the ubuntu drive first. But it still boots vista first that is the problem. Again i am sorry i have bad eyes and it is difficult for me to use my tablet at times i should probably just sell it ,and buy a laptop.
    Thanks
    Dc

    Sent from my GT-N8013 using Tapatalk HD

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,107
    Did you install the Ubuntu Grub bootloader to the master boot record of the second drive during the installation?
    If so, it should boot Ubuntu when you select that drive. If you did not, then it won't boot unless you configure the windows boot loader to boot Ubuntu.
    To get more detailed information to post, you could go to the site below and download and run the bootinfoscript and post the output. You will need to run it from a Live Linux system on a CD or flash drive.

    Boot Info Script | Free System Administration software downloads at SourceForge.net

  5. #5
    Just Joined!
    Join Date
    Apr 2013
    Posts
    14
    Yes, and it does boot grub when I Manuelly boot from the boot menu. But the linux drive won't boot first when I change the boot order in bios. But yes when I do the f12 thing it comes up fine. I can live with it but its a little inconvenient
    Thanks
    Dc

    Sent from my GT-N8013 using Tapatalk HD

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,107
    Are you sure you checked all the options in the BIOS? Save the changes? I had 2 options in my machine to boot from usb, one worked the other didn't. If you ran the bootinfoscript and posted it someone might be able to make a suffestion. The bootinfoscript is handy to have as it contains a lot of information on drives/partitions and boot files.

  7. #7
    Just Joined!
    Join Date
    Apr 2013
    Posts
    14
    I'll run the script when I get home and post it I'm on the road till later tonight early tomorrow. I will also recheck
    bios I updated the system to 12.1 from 12 04.2 before I left. Thanks again
    dc

  8. #8
    Just Joined!
    Join Date
    Apr 2013
    Posts
    14
    thanks yancek checked bios again and i screwed up.
    works now
    thanks
    dc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •