Find the answer to your Linux question:
Results 1 to 4 of 4
Very new to Linux. Information is needed for a class. I recently downloaded Centos 6.4 Minimal for use on Virtual Box. I also downloaded puTTY for Windows 7. My SSH ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2013
    Posts
    2

    SSH Failure regarding CENTOs VM and Windows 7.


    Very new to Linux. Information is needed for a class.

    I recently downloaded Centos 6.4 Minimal for use on Virtual Box. I also downloaded puTTY for Windows 7. My SSH is not working. In Virtualbox, I have changed the first adapter to Bridged Adaptor.

    When I run ifconfig in VM, My IP is the LO 127.0.0.1 (that might not be exactly right, not at my home computer) Basically I am not getting an ethernet IP address.

    When I pull up puTTY and do an SSH check, I get a failure error before it even gives me any opportunity to log into my VM from puTTY.

    Any ideas? Please feel free to dumb down any response to me. Super new to this and won't be offended!

    Thank you

  2. #2
    Linux Newbie
    Join Date
    Jan 2013
    Posts
    116
    If you have restart your computer then you needed to run ifup command for yout eth.

    Please try after run this command:

    Code:
    ifup eth0

  3. #3
    Just Joined!
    Join Date
    May 2013
    Posts
    2
    Do I run this in the VM terminal. If so, it this what creates the eth IP address?

  4. #4
    Linux Newbie
    Join Date
    Jan 2013
    Posts
    116
    Yes, run this in VM terminal. It will not create IP Address, It will only up etho. You can check if IP is assigned to eth0 as:

    Code:
    #cat /etc/sysconfig/network-scripts/ifcfg-etho
    run

    Code:
    ifup eth0
    and then you can check ip simply with

    Code:
    ifconfig 
    or 
    ip a

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •