Find the answer to your Linux question:
Results 1 to 6 of 6
Hi Guys, I had a powercut which seems to have taken out my WD MYBOOK Live drive. Disk is now in a pc along side an 80GB drive. I've booted ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2013
    Posts
    3

    Hard Disk Crash


    Hi Guys, I had a powercut which seems to have taken out my WD MYBOOK Live drive. Disk is now in a pc along side an 80GB drive.
    I've booted using the ubuntu rescue remix v12.04 to see if I can recover but having trouble. Going to add a screen dump here in the hope someone can help. I have one folder in particular I need to try to recover. Can anyone help. Please
    Attached Images Attached Images

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hello and welcome, jerbear!

    /dev/sr0 is an optical disk (CD/DVD). if sda is your 80GB drive, then it seems your WD MYBOOK driver is not showing up at all. it should be /dev/sdb or similar.

    are you sure the drive is plugged in and getting power? how is it in the pc anyway? attached via IDE, SATA, USB, etc.

  3. #3
    Just Joined!
    Join Date
    Oct 2013
    Posts
    3
    Thanks Atreyu. That would explain that then. I'm a "Windows" user..please don't hate me. Just getting into Linux now as I need to. The drive in question will show up under windows but it tells me it needs formatted. Under Linux It was connected via the motherboard but I have also tried putting it into a HD Caddy and connecting vis USB. No change. Wondering is there any software available for windows that would help recover a Linux disk. I have a couple of packages, iCare and Power Data Recovery. Didn't want to try them in case I did more harm to the drive. I have two of these MyBook drives. I tried swapping the disks but that didn't work, then I tried swappping the HDD circuit boards as both drives are the same make and model. But that didn't work either. Anyone got any ideas what I could try next.........

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    if you can access it via Windows, you should be able to access it via Linux. when you can access it via Windows, how is it attached? Via USB or IDE/SATA? just boot up the same configuration using a Linux CD in rescue mode and you should be able to see all connected drives via "fisk -l" (lower case L). you can also look for disks using dmesg, e.g.:

    Code:
    dmesg|grep sd
    I use SysRescCD for doing hard drive recoveries, but the latest Ubuntu CD should be fine, too.

  6. #5
    Just Joined!
    Join Date
    Oct 2013
    Posts
    3
    OK. In windows It's attached in my USB toaster and I'm attaching a screen shot of how it's detected. As an uninitialised disk and it's asking me to initialise it. Obviously, I'm not keen on doing this until I'm sure it's the right thing to do.

    I've attached it the same way to the linux system and have used fdisk and dmesg but it will not show up. I've alos attached it internally with the same negative result.

    Wondering now should I initialise it on the PC then try to run my recovery software on it on that platform.

    For the record....Western Digital have told me the White MyBook Terabyte drives are Linux based. I hope they got that right....!
    Attached Images Attached Images

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    i think that to initialize the drive in Windows is to say goodbye to recovering files on it.

    however, if you can't even see the drive when booted into Linux, then you may be hosed anyway, unfortunately.

    I would *really* be sure before writing it off though. you might want to consider posting your entire dmesg output here, as an attachment (or pastebin link or whatever), so that we can get a full picture of what is going on underneath the hood. so if that sounds like something you are willing to do, then first make sure the system can see the drive in Windows (as per your attachment), then shutdown and boot up with a recent version of any Live Linux CD. Then mount a thumb drive to the system, once booted up (say to /mnt/thumbdrive). then do:

    Code:
    dmesg > /mnt/thumbdrive/dmesg.txt
    then attach that file to this thread.

    btw, i mentioned System Rescue CD, but also maybe check out Hiren's BootCD, it is another popular tool used by folks who experience hard drive failures (so I've read - never used that one myself).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •