Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Starting with Linux I tried liveCD's (Ubuntu, OpenSuse, Fedora, Mint) and installed Mint Petra Cinnamon. (Motherboard Gigabyte M68MT-D3P, integrated graphic and sound NVIDIA GeForce 7025, Realtek ALC889). After some troubles ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2014
    Posts
    6

    strong noise in the sound


    Starting with Linux I tried liveCD's (Ubuntu, OpenSuse, Fedora, Mint) and installed Mint Petra Cinnamon. (Motherboard Gigabyte M68MT-D3P, integrated graphic and sound NVIDIA GeForce 7025, Realtek ALC889). After some troubles with graphic it is now OK except the strong noise in the sound (in all cases). Increasing the volume increases the noise, too. Installing another realtek audio driver and playing with Alsamixer or PulseAudio didn't improve it. In Win XP the sound is perfect. Is there´s a chance?

  2. #2
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,294
    If you are using pulseaudio there is a bug in the alsa driver for some of the intel chipsets. The fix is to turn off glitch free mode. Find the line starting "load-module module-udev-detect" in the file "/etc/pulse/default.pa" and change use_ucm=0 to tsched=0 or add tsched=0 to the end.
    Code:
    load-module module-udev-detect tsched=0
    then run:
    Code:
    pulseaudio --kill && pulseaudio --start
    to stop and start it.

  3. #3
    Just Joined!
    Join Date
    Jan 2014
    Posts
    6
    For a newbie - could it be more detailed? I tried these commands, they were not accepted. Or can this change be done with the interface of PulseAudio?

  4. #4
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,294
    You need to be root or use sudo. Open a terminal and
    Code:
    cd /etc/pulse
    . You should use what ever your favorite text editor is. From the terminal type:
    Code:
    sudo vim default.pa
    replacing vim with the editor of your choice. Search for the line that starts "load-module module-udev-detect" and edit it to be
    Code:
    load-module module-udev-detect tsched=0
    then execute the command:
    Code:
    sudo pulseaudio --kill && pulseaudio --start
    . The command "sudo" allows you to execute the command with the privileges of the superuser.

  5. #5
    Just Joined!
    Join Date
    Jan 2014
    Posts
    6
    I went succesfully to the last command but then i got:
    E: [pulseaudio] core-util.c: Home directory not accessible: denied
    E: [pulseaudio] main.c: Deamon not killed: Success

  6. #6
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,294
    Code:
    sudo pulseaudio --kill && sudo pulseaudio --start

  7. #7
    Just Joined!
    Join Date
    Jan 2014
    Posts
    6
    Thanks for your time, but still no result. It looks as if my motherboard and Linux don't like each other. It's really a shame, I like this Mint more and more.

  8. #8
    Just Joined!
    Join Date
    Jan 2014
    Posts
    6
    Quote Originally Posted by tiedzig View Post
    Thanks for your time, but still no result. It looks as if my motherboard and Linux don't like each other. It's really a shame, I like this Mint more and more.
    Since nothing helped while the Windows sound is good, I have one more question: could this be solved with Wine?

  9. #9
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,294
    Have you installed drivers from realtek? I don't think wine will help.

  10. #10
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,565
    I used to get a very annoying buzzing if the volume was over 100% in the sound settings of whatever distro I was running. I don't mean the icon in the system tray although it may have a link into the settings on it's menu.
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •