Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
Like Tree1Likes
I have no idea what this means, but apparently my kernals in a panic. I turned my laptop on, went to make tea and came back to a black screen. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Mar 2014
    Posts
    133

    [beginner] HELP Kernal Panic!


    I have no idea what this means, but apparently my kernals in a panic.

    I turned my laptop on, went to make tea and came back to a black screen. So I forced my comp off, turned it back on, there were some boot options that I've not seen before so I went into recovery to be safe and got the following screen :

    LINK TO IMAGE(forum uploads aren't working?)

    I've not idea what I'm meant to do with this screen, other than perhaps manually mount the root fs ? I've no idea how this would be done though...

    cheers

  2. #2
    Linux Newbie
    Join Date
    Mar 2014
    Posts
    133
    I found this site

    Chapter*7.*Configuring a Linux Kernel

    That has a bit about 'unable to mount root fs' but I don't know what any of it means. My computer isn't moving on from the screen it's on at the moment, and I can't seem to enter anything.

  3. #3
    Linux Guru Lakshmipathi's Avatar
    Join Date
    Sep 2006
    Location
    3rd rock from sun - Often seen near moon
    Posts
    1,769
    Kernel panic is refer to crash.

    Its says unable to open your root partition "sda1" and fails.
    You can try adding 'rootfs' option in the boot parameter and see whether it helps or not.

    Check page -99 http://files.kroah.com/lkn/lkn_pdf/ch09.pdf "root disk options"

    Or you can use Live CD login the machine and try to mount /dev/sda1 on /mnt See whether it gives out any error message or not.
    First they ignore you,Then they laugh at you,Then they fight with you,Then you win. - M.K.Gandhi
    -----
    FOSS India Award winning ext3fs Undelete tool www.giis.co.in. Online Linux Terminal http://www.webminal.org

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Did you make any changes to the prior to shutting down the last time it worked and if so, what?

    It can't mount the root partition on sda1 so use the installation medium or any Linux Live CD and mount sda1. You need root privileges to do that.

    mount /dev/sda1 /mnt should do it. Then navigate to the /mnt directory on the Live CD and go to the /boot/grub/grub.cfg file and post it here. You might also look at its /etc/fstab file to see if you have an entry for sda1, post it.

  6. #5
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,205
    Try a live session. I am wondering if your kernel panic might be your hard drive failing.

    In other words. Maybe your hard drive is worn out.

    You can run a check in gparted on your hard drive while running a live session

    http://i2.wp.com/imagecdn5.maketeche...filesystem.png

    Edit: yanek beat me to the post so you might want to disregard my suggestion and follow his instructions instead.

  7. #6
    Linux Newbie
    Join Date
    Mar 2014
    Posts
    133
    hi all - thanks for the responses. Currently I have shut the computer down (forced again) and it's off. I have my (smug) Windows 8 Computer and a USB stick.


    Consensus seems to be to create a Live USB / CD, boot from there, try some of the suggestions and report back?



    Quote Originally Posted by Lakshmipathi View Post
    Kernel panic is refer to crash.

    Its says unable to open your root partition "sda1" and fails.
    You can try adding 'rootfs' option in the boot parameter and see whether it helps or not.
    I couldn't enter anything into the screen that was on before, not sure where you mean for this.

    Check page -99 http://files.kroah.com/lkn/lkn_pdf/ch09.pdf "root disk options"
    I'll have a look thanks

    Or you can use Live CD login the machine and try to mount /dev/sda1 on /mnt See whether it gives out any error message or not.

    OK, this might be the best option (for me) seeing as I've made one before.

    Quote Originally Posted by yancek View Post
    Did you make any changes to the prior to shutting down the last time it worked and if so, what?
    None - I had been using it the night before and shut it down without any noticeable problems.
    It can't mount the root partition on sda1 so use the installation medium or any Linux Live CD and mount sda1. You need root privileges to do that.
    OK - so Live CD / USB ?


    mount /dev/sda1 /mnt should do it. Then navigate to the /mnt directory on the Live CD and go to the /boot/grub/grub.cfg file and post it here. You might also look at its /etc/fstab file to see if you have an entry for sda1, post it.
    Thank you, I'll create a live USB and try and get that Info.

    Quote Originally Posted by rokytnji View Post
    Try a live session. I am wondering if your kernel panic might be your hard drive failing.
    Ah I hope not! I have a spare USB hard drive that perhaps could temporarily replace it... :/
    In other words. Maybe your hard drive is worn out.

    You can run a check in gparted on your hard drive while running a live session
    And this will show whether the hard drive has issues? Ace


    Edit: yanek beat me to the post so you might want to disregard my suggestion and follow his instructions instead.
    All good thank you

  8. #7
    Linux Newbie
    Join Date
    Mar 2014
    Posts
    133
    Riiiight, took me a while to get back to my computer but I've attached a screen shot


    going to try booting it on the main drive now


    edit - better screen shot Screenshot2.jpg
    Attached Images Attached Images

  9. #8
    Linux Newbie
    Join Date
    Mar 2014
    Posts
    133
    argh - here's an imgur link - http://i.imgur.com/mdAgcQJ.png

  10. #9
    Linux Newbie
    Join Date
    Mar 2014
    Posts
    133
    OK i took the USB out and tried to start the system and it still has the error from before

    [ 4.149696] kernal panic-not syncing : VFS : Unable to mount root fs on unknown-block (0,0)

    I'm going to go back into it and try the mount /dev/sda1 /mnt


    here's the report from gparted (not sure if it means anything)


    <!DOCTYPE html PUBLIC '-//W3C//DTD XHTML 1.0 Transitional//EN' 'http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd'>
    <html xmlns='http://www.w3.org/1999/xhtml' xml:lang='en-US' lang='en-US'>
    <head>
    <meta http-equiv='Content-Type' content='text/html;charset=utf-8' />
    <title>GParted Details</title>
    </head>
    <body>
    <p>GParted 0.16.1 --enable-libparted-dmraid</p>
    <p>Libparted 2.3</p>
    <table border='0'>
    <tr>
    <td colspan='2'>
    <b>Check and repair file system (ext4) on /dev/sda5</b>&nbsp;&nbsp;00:00:10&nbsp;&nbsp;&nbsp;&nbsp;( SUCCESS )
    </td>
    </tr>
    <tr>
    <td>&nbsp;&nbsp;&nbsp;&nbsp;</td>
    <td>
    <table border='0'>
    <tr>
    <td colspan='2'>
    calibrate /dev/sda5&nbsp;&nbsp;00:00:02&nbsp;&nbsp;&nbsp;&nbsp;( SUCCESS )
    </td>
    </tr>
    <tr>
    <td>&nbsp;&nbsp;&nbsp;&nbsp;</td>
    <td>
    <table border='0'>
    <tr>
    <td colspan='2'>
    <i>path: /dev/sda5<br />start: 80003072<br />end: 1447188479<br />size: 1367185408 (651.92 GiB)</i>
    </td>
    </tr>
    </table>
    </td>
    </tr>
    </table>
    <table border='0'>
    <tr>
    <td colspan='2'>
    check file system on /dev/sda5 for errors and (if possible) fix them&nbsp;&nbsp;00:00:08&nbsp;&nbsp;&nbsp;&nbsp;( SUCCESS )
    </td>
    </tr>
    <tr>
    <td>&nbsp;&nbsp;&nbsp;&nbsp;</td>
    <td>
    <table border='0'>
    <tr>
    <td colspan='2'>
    <b><i>e2fsck -f -y -v /dev/sda5</i></b>
    </td>
    </tr>
    <tr>
    <td>&nbsp;&nbsp;&nbsp;&nbsp;</td>
    <td>
    <table border='0'>
    <tr>
    <td colspan='2'>
    <i>Pass 1: Checking inodes, blocks, and sizes<br />Pass 2: Checking directory structure<br />Pass 3: Checking directory connectivity<br />Pass 4: Checking reference counts<br />Pass 5: Checking group summary information<br /><br /> 19066 inodes used (0.04%, out of 42729472)<br /> 469 non-contiguous files (2.5%)<br /> 67 non-contiguous directories (0.4%)<br /> # of inodes with ind/dind/tind blocks: 0/0/0<br /> Extent depth histogram: 18977/73<br /> 8371579 blocks used (4.90%, out of 170898176)<br /> 0 bad blocks<br /> 2 large files<br /><br /> 16020 regular files<br /> 3023 directories<br /> 0 character device files<br /> 0 block device files<br /> 1 fifo<br /> 0 links<br /> 10 symbolic links (4 fast symbolic links)<br /> 3 sockets<br />------------<br /> 19057 files<br /></i>
    </td>
    </tr>
    </table>
    <table border='0'>
    <tr>
    <td colspan='2'>
    <i>e2fsck 1.42.8 (20-Jun-2013)<br /></i>
    </td>
    </tr>
    </table>
    </td>
    </tr>
    </table>
    </td>
    </tr>
    </table>
    <table border='0'>
    <tr>
    <td colspan='2'>
    grow file system to fill the partition&nbsp;&nbsp;00:00:00&nbsp;&nbsp;&nbsp;&nb sp;( SUCCESS )
    </td>
    </tr>
    <tr>
    <td>&nbsp;&nbsp;&nbsp;&nbsp;</td>
    <td>
    <table border='0'>
    <tr>
    <td colspan='2'>
    <b><i>resize2fs /dev/sda5</i></b>
    </td>
    </tr>
    <tr>
    <td>&nbsp;&nbsp;&nbsp;&nbsp;</td>
    <td>
    <table border='0'>
    <tr>
    <td colspan='2'>
    <i></i>
    </td>
    </tr>
    </table>
    <table border='0'>
    <tr>
    <td colspan='2'>
    <i>resize2fs 1.42.8 (20-Jun-2013)<br />The filesystem is already 170898176 blocks long. Nothing to do!<br /><br /></i>
    </td>
    </tr>
    </table>
    </td>
    </tr>
    </table>
    </td>
    </tr>
    </table>
    </td>
    </tr>
    </table>
    <p>========================================</p>
    </body>
    </html>

  11. #10
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,205
    Ok, the check in gparted found nothing wrong with the file structure inside of your Linux partition so that seems OK. It does not check mechanical hard drive failure though.

    I know improper shutdowns on flash drives cause kernel panic (on usb installs like when I ran Puppeee Linux on a external SD falsh drive) because I have experienced this myself. It corrupts the write to hard dfrive partitions file system with improper power off.

    So.

    It can't mount the root partition on sda1 so use the installation medium or any Linux Live CD and mount sda1. You need root privileges to do that.

    mount /dev/sda1 /mnt should do it. Then navigate to the /mnt directory on the Live CD and go to the /boot/grub/grub.cfg file and post it here. You might also look at its /etc/fstab file to see if you have an entry for sda1, post it.

    Or you can use Live CD login the machine and try to mount /dev/sda1 on /mnt See whether it gives out any error message or not.
    Seems the next step to me.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •