Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Display issues with Nvidia


    Hi,

    I have a major issue with screen rendering, when showing some window that has multiple tabs like firefox or settings of something the view gets stuck and doesn't refresh the current display so unless i move my mouse over it or move the window or something it doesn't show the current view, sometimes even when scrolling.

    I'm Running Xfce with Compiz but i think the issue is with the drivers, i have a gtx570 card and when i disabled the nvidia drivers and installed the Nouveau driver i didn't have these issues so something in the nvidia drivers is causing that.

    Any ideas?

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,907
    You don't say which distribution you are running but in Mint 17 Xfce with Compiz and Emerald window decorator is fine with a GT 610 and the 331.38 drivers.

    There was one point when it went completely mad, to the point I couldn't even begin to describe what it was doing but dropping back to the Xfce window manager, rebooting and then restarting compiz seems to have fixed it.

    Alt + F2 and enter xfwm4 --replace, reboot and then Alt + F2 and enter compiz --replace.
    Should you be sitting wondering,
    Which Batman is the best,
    There's only one true answer my friend,
    It's Adam Bloody West!


    The Fifth Continent

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    13,745
    Quote Originally Posted by Riptaz View Post
    Hi,

    I have a major issue with screen rendering, when showing some window that has multiple tabs like firefox or settings of something the view gets stuck and doesn't refresh the current display so unless i move my mouse over it or move the window or something it doesn't show the current view, sometimes even when scrolling.

    I'm Running Xfce with Compiz but i think the issue is with the drivers, i have a gtx570 card and when i disabled the nvidia drivers and installed the Nouveau driver i didn't have these issues so something in the nvidia drivers is causing that.

    Any ideas?
    Usually it is the other way around!
    What version of the nVidia drivers are you using? Also, which Linux distribution+version+kernel are you running?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
    $spacer_close
  5. #4
    Thanks For all the help! Managed to solve the issue by using Compiz Workarounds.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •