Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Ethernet modem problems

    I have an aztech ethernet modem 305E and RH linux 8. My present hardware connections are 1 LAN card (realtek) connected to the modem. In windows xp, the ethernet modem works at last.

    However in linux,the modem still cannot surf the net. I have tried a few methods. Here goes:

    1) I set up my LAN card to use DHCP and auto get DNS.
    2) I set up my LAN card to static IP addresses ( and subnet mask .
    3) For the connection itself, I use 'adsl-setup' to setup ppp0. The settings for adsl-setup are - root:name@singnet / auto get DNS from ISP / connection to be on continuously / no firewall / do not activate ppp0 on bootup
    4) I used the graphical program to setup ppp0, which basically ask the same settings with adsl-setup

    I used different combinations with the above 4 methods but none worked. In mozilla, if I type the modem's ip address,there's a message saying 'unable to connect to'. For adsl-start, there will be a message saying 'link is down' or 'terminated' after a while. Then lastly, if I activate ppp0 using the graphical program, ppp0 will be activated for several seconds b4 it becomes deactivated again.

    Do you know of any solutions ? Please reply quickly if you can....thanks!!

  2. #2
    Linux User
    Join Date
    May 2003
    if you use DHCP to auto-configure your network interfaces,
    what is the output of
    ifconfig -a
    netstat -rn
    do you get error messaages of any kind?

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Täby, Sweden
    Are your connection really PPPoE?

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts