Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Just to follow on from this above - I've moved the commands from /etc/fstab to .bash_profile and changed the smb permissions as above (chmod u+s /usr/bin/smbmount) and I get the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jun 2003
    Posts
    9

    Just to follow on from this above - I've moved the commands from /etc/fstab to .bash_profile and changed the smb permissions as above

    (chmod u+s /usr/bin/smbmount)

    and I get the following error when attempting to mount:

    libsmb programs must *NOT* be setuid root

    I suspect I've got one more step but I cant work it out.
    Thanks again

  2. #12
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You shouldn't have it in your .bash_profile anyway, since that will attempt to mount those shares every time you log in, which can cause problems, and even if it doesn't, it's quite ugly.

    As for why it hangs, could it have with the passwords to do? Have you put a password mount option in all fstab entries?

  3. #13
    Just Joined!
    Join Date
    Jun 2003
    Posts
    9
    thanks again - after spending several hours of rebooting and changing fstab there is a pattern (almost).

    For a single smb mount entry it works fine.
    For two smb mount entries is fails nearly every time but not always! I have tried various parameter settings, with and without passwords but no other pattern is visable.

    The entries are:
    Code:
    //server/Shareddocs /home/shared smbfs username=david,password=david,uid=david,gid=users 0 0
    //server/davesdocs /home/david/docs smbfs username=david,password=david,uid=david,gid=users 0 0
    random thoughts for your consideration?
    Both are quite long lines with the second wrapping slightly in the editor
    I can get smbmount to lock up randomly by entering either one of these commands repetiitively into a terminal.
    I'm really lost

  4. #14
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That is strange. It seems almost as if the Windows computers aren't responding or something, but for once, I don't suspect the fault to be in Windows.
    Would you mind trying to recompile your kernel?

  5. #15
    Just Joined!
    Join Date
    Jun 2003
    Posts
    9
    thank you - I've now found out that it is a known bug in RedHat 9.
    kind regards and thanks for the help.
    D>

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •