Find the answer to your Linux question:
Results 1 to 3 of 3
Thanks for the replies yesterday. I have 2 linux boxes running Mandrake 9. On my home machine, it is a dual Mandrake 9 / Win XP. On the work machine ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2002
    Posts
    5

    Forgotten Password Part 2 (/usr/bin/passwd not found)


    Thanks for the replies yesterday.

    I have 2 linux boxes running Mandrake 9. On my home machine, it is a dual Mandrake 9 / Win XP. On the work machine it is purely a Linux box.

    I followed the suggestions from the pervious post, i.e

    1) boot: linux init=/bin/sh
    2) mount -o remount,rw /
    3) /usr/bin/passwd

    and resetted the root password very nicely!

    I got in this morning very hopeful indeed that this would be good on the work machine. NO.

    1) boot: linux init=/bin/sh
    2) mount -o remount,rw /
    3) /usr/bin/passwd

    init: /usr/bin/passwd no such file or directory

    Now the only thing I can think of is that the work machine was setup on different mount points or something. I really don't know as I am not that clued up on that. With my home machine I just set the default partitioning scheme I think.

    Does anyone know if I need to mount other devices or execute the passwd from somewhere else. I tried /sbin/passwd and /bin/passwd but no luck there either.

  2. #2
    Just Joined!
    Join Date
    Dec 2002
    Posts
    5
    problem solved.

    enter rescue mode:

    chroot /mnt
    passwd

    easy peasy!

  3. #3
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    you have /usr on a separate partition probably. Had you mounted it that would have worked too. Oh well, glad to see you got it fixed.
    I respectfully decline the invitation to join your delusion.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •