Find the answer to your Linux question:
Results 1 to 8 of 8
Hello - I'm runnig SuSE 8.1 -> My burner works but ineffeciently. It uses nearly ALL of my 2.53 Ghz processor... I have 512 Mb RAM and am using a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    Poor CD burning performance


    Hello -
    I'm runnig SuSE 8.1 -> My burner works but ineffeciently. It uses nearly ALL of my 2.53 Ghz processor... I have 512 Mb RAM and am using a genuine INTEL chipset. The burner is a 40x write, 12x rewrite and 52x read (think) Why is this using all my processor??

    Cole

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What program are you using and what are you burning?

  3. #3
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    K3b

    I'm using k3b and it is the same when I'm burning music, ISO, or custom data CD's

    If it helps any the same thing happens when it's readin from the CD - when I'm playing quake 3 or Diablo II the movies will skip and become out of sync - this is the case with both cd drives

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That seems pretty extreme, but check anyway so that DMA has been enabled on your CD with "hdparm -d /dev/hdc" (if your CD isn't hdc, just replace it).

  6. #5
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    hdparm -

    well being one step ahead of you I had alrady tried this - "DMA not supported by this device"

    SCSI emulation has been enabled so that I can burn - I have /dev/sr0 and /dev/sr1(burner)

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Are you using the standard SuSE kernel? Chances are that it doesn't include support for your IDE chipset. Would you mind recompiling your kernel?

  8. #7
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    recompiling -

    Yes, i'm using the default SuSE kernel - I've never recompiled the kernel before but I'm pretty confident that it shouldn't be a problem. What do you suggest to try to make this work?

  9. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Make sure to compile support for your IDE chipset. If you don't know which one you have, check with /sbin/lspci.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •