Find the answer to your Linux question:
Page 4 of 4 FirstFirst 1 2 3 4
Results 31 to 34 of 34
True... Try to manually remove all .o files in drivers/scsi and then recompile. Not that it should make any difference, but maybe there's some kind of Makefile bug. Also, while ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578

    True... Try to manually remove all .o files in drivers/scsi and then recompile. Not that it should make any difference, but maybe there's some kind of Makefile bug. Also, while it's compiling, check the gcc command lines for compiling the SCSI files so that they include "-include /usr/src/linux/include/linux/modversions.h".

  2. #32
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    I was thinking, even if I forgot the "make modules_install" step, the drivers would still be there from the other time I compiled. In all honesty, I think I ran that last step but it's possible that I forgot to run it. Either way, thanks for all the help Dolda. It's working beautifully now.
    The best things in life are free.

  3. #33
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Oh well... as long as it works...
    I guess module versioning is causing more problems than it actually solves.

  4. #34
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    I'd like to state running this command
    Code:
       rm -rf include/linux/modules include/linux/modversions.h && make clean
    is critical in getting this to work. I had to enable something in my kernel and after recompiling, I noticed that if I didn't run the command above, the SCSI drivers would not load.
    The best things in life are free.

Page 4 of 4 FirstFirst 1 2 3 4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •