Find the answer to your Linux question:
Results 1 to 8 of 8
I'm getting like average 4MB/s when I'm transfering files from one HD to another HD. I used to have windows install on this machine so I know it can go ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2003
    Posts
    13

    Slow Data Transfer from HD to HD


    I'm getting like average 4MB/s when I'm transfering files from one HD to another HD. I used to have windows install on this machine so I know it can go alot faster then that! also, I think i'm getting about the same speed when sharing files across the network. I do have 100Mb on board ethernet, but it's just not getting faster then 4Mb

    I'm on a 2.4 Ghz P4, Mandrake 9.1.

    can anyone help me on trying to get this to run faster?

  2. #2
    Just Joined!
    Join Date
    Jul 2003
    Posts
    7

    solution

    Your hdds probably dont have udma mode enabled.While you installed kernel should have found this...Maybe your bios doesnt report it correctly-yolution is to use hdparm-read carefully this-can damage your hardware-what is your mainboard chipset and disks?

  3. #3
    Just Joined!
    Join Date
    Jul 2003
    Posts
    13
    I can run hdparm -I /dev/hda and this is what I get... i'm not sure if this is what you're asking for though. I'm also not sure how to find out info about my motherboard, since this was a pre-built gateway computer.

    /dev/hda:

    ATA device, with non-removable media
    Model Number: WDC WD800BB-53CAA1
    Serial Number: WD-WMA8E4190152
    Firmware Revision: 17.07W17
    Standards:
    Supported: 5 4 3 2
    Likely used: 6
    Configuration:
    Logical max current
    cylinders 16383 16383
    heads 16 16
    sectors/track 63 63
    --
    CHS current addressable sectors: 16514064
    LBA user addressable sectors: 156301488
    device size with M = 1024*1024: 76319 MBytes
    device size with M = 1000*1000: 80026 MBytes (80 GB)
    Capabilities:
    LBA, IORDY(can be disabled)
    bytes avail on r/w long: 40 Queue depth: 1
    Standby timer values: spec'd by Standard, with device specific minimum
    R/W multiple sector transfer: Max = 16 Current = 16
    Recommended acoustic management value: 128, current value: 254
    DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5
    Cycle time: min=120ns recommended=120ns
    PIO: pio0 pio1 pio2 pio3 pio4
    Cycle time: no flow control=120ns IORDY flow control=120ns
    Commands/features:
    Enabled Supported:
    * READ BUFFER cmd
    * WRITE BUFFER cmd
    * Host Protected Area feature set
    * Look-ahead
    * Write cache
    * Power Management feature set
    Security Mode feature set
    * SMART feature set
    * Device Configuration Overlay feature set
    Automatic Acoustic Management feature set
    * SET MAX security extension
    * DOWNLOAD MICROCODE cmd
    * SMART self-test
    * SMART error logging
    Security:
    supported
    not enabled
    not locked
    not frozen
    not expired: security count
    not supported: enhanced erase
    HW reset results:
    CBLID- above Vih
    Device num = 0 determined by the jumper
    Checksum: correct

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2003
    Posts
    13
    I was looking through the kcontrol and inside the kernel source and found this..

    Special UDMA Feature ( CONFIG_PDC202XX_BURST )

    I've never really changed anything in my kernel before so I'm wondering if I activate this, and it messes something up, is there a way for me to correct it? I'm sure this shouldn't be a problem, but I want to be safe, and somewhat know what I'm doing before I do it.

  6. #5
    Just Joined!
    Join Date
    Jul 2003
    Posts
    7

    yes

    You should try and enable it this option, but backup your data first.if you do it, you should compile kernel with different name and put it in lilo or grub-so you can boot new and old one-most likely it should work.Good luck.

  7. #6
    Just Joined!
    Join Date
    Jul 2003
    Posts
    13
    ok I just finished that, and my new kernel works... but i'm still not getting any faster transfer speeds.... if there a way for me to test my bandwidth?

    I ran a test on my hard drives and for hda i'm getting

    Timing buffer-cache reads: 128 MB in 0.33 seconds =387.88 MB/sec
    Timing buffered disk reads: 64 MB in 2.47 seconds = 25.91 MB/sec

    and for hdb i'm getting

    Timing buffer-cache reads: 128 MB in 0.31 seconds =412.90 MB/sec
    Timing buffered disk reads: 64 MB in 2.01 seconds = 31.84 MB/sec

    This means that I should be getting around 350Mb/s when transfering files of 500Mb + from HD to HD...

  8. #7
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    A lot of your hard disk speed will be limited by things such as the speed of your motherboard HD controller. Also, i think that having the hard disks on seperate "ribbons" inside your PC may speed things up a bit.

    Jason

  9. #8
    Just Joined!
    Join Date
    Jul 2003
    Posts
    13
    well I know when I was running windows on this same machine that it was transfering a lot faster, i'm sure that my computer can handle faster then 4MB/s! how would I find out what speed my motherboard can transfer at? i can try to put my hard drive on another ribbon, but i just don't think that's really going to solve my issue... I tried to transfer data through the console also, and it was still the same speed. is there like a buffer somewhere I can tweak or something? besides on my HD because it's just as slow across the network too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •