Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
Hello again! I am runnig SuSE 8.1 and since I installed it, I have been unable to listen to audio CD's... I'm runnig KDE and there's supposed to be some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    Audio CD's


    Hello again!
    I am runnig SuSE 8.1 and since I installed it, I have been unable to listen to audio CD's... I'm runnig KDE and there's supposed to be some cool stuff built into it... Also in k3b when I try to copy a CD if won't find that drive even though it's configured in the settings. Has anybody has similar issues and did you find a way to resolve them?

    Cole

  2. #2
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Which program do you use to run the audio cds?
    The best things in life are free.

  3. #3
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    KsCD

    When I doulbe click the CD Icon on the desktop it automatically lodas KsCD.

    Whne I issue a mount -t auto /dev/sr0 /media/cdrom

    it returns with the following :

    Code:
    cole@DrSpin:~> su
    Password:
    DrSpin:/home/cole # mount -t auto /dev/sr0 /media/cdrom
    /dev/sr0: Input/output error
    mount: block device /dev/sr0 is write-protected, mounting read-only
    /dev/sr0: Input/output error
    mount: you must specify the filesystem type
    I get the smae thing when I right-click and issue a mount on the KDE desktop... at last it's VERY similar.

    Cole

  4. #4
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    You can't mount audio cd's since they don't have a filesystem.

  5. #5
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Open kscd and try opening the device (in your case /dev/sr0). As genlee put it, you cannot mount audio CDs since they don't have a format.
    The best things in life are free.

  6. #6
    Linux Newbie
    Join Date
    Apr 2003
    Location
    UK, Manchester
    Posts
    147
    Quote Originally Posted by genlee
    You can't mount audio cd's since they don't have a filesystem.
    Thats not true, you can mount an audio cd using the cdfs or cddafs filesystem.

  7. #7
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    CDFS and CDAFS

    I would like to know some more about these filesystems... could you sum up their differnet purposes and the functionality/useability for me??

    cole

  8. #8
    Linux Newbie
    Join Date
    Apr 2003
    Location
    UK, Manchester
    Posts
    147
    I have never used them personally but I have links if you want to read up on them.

    CDFS and CDDAFS.

    I use a plugin for xmms called cdread that reads audio cds (imagine that ), all you do is just point to the device. It also contacts a freedb and gets the titles of the tracks.

  9. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Check your mixer settings so that CD audio isn't just turned off.

  10. #10
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    mixer

    dolda, the mixer settings are fine and unmuted I haven't had a chance to try selecting /dev/sr0 explicitly yet... I'll let you know

    Cole

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •