Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, i had installed mandrake 8.2 on my really old machine. That was a real test of my perseverance! i did manage to install it in the text mode. It ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2003
    Posts
    5

    HELP....40 40 40 ..... is all get on boot up!!! :-(


    Hi,
    i had installed mandrake 8.2 on my really old machine. That was a real test of my perseverance! i did manage to install it in the text mode. It turned out be real slow and really, really, really bad graphics. After discarding it for a while, i jus' forgot both root and user password. The password was jus' too creative to recollect! Finally decided to try RedHat7.1 after heaps of reading n' searching to check my hardware compatibility.

    The spec (as i know!!!) is :
    *CPU: AMD5k86-P75
    *Sound: C-Media CM8738
    *Graphics: SIS6202
    *Cdrom: ATAPI

    *Modem: Rockwell HCF56K Data/Fax/voice
    *Harddisk: Seagate (not sure of exact spec)

    But when i tried booting the Redhat 7.1installation CD, again it needed to go to text mode. The it would crash after the message "hard disk problem. Specify the geometry manually and come back".... I didn't have a clue about that message. Finally i decided to format my harddisk. Went to sytem setup - pressing "del" at the system startup. Went to the HDD screen and did the preformat option.
    Now all i get when on loading is a very long list of 40s!!!!!

    I would really appreciate if any of you could help me figure this out and suggest the best linux version for my system - mandrake or redhat(and version too...) As soon i get that right, i might start on my linux from scratch project.

    All i need my system to do is the list of following applications:
    emacs
    mozilla
    openoffice
    g++
    java
    gimp
    latex
    gv
    xdvi
    acroread
    enscript - ascii to ps conversion
    ps2pdf
    dvips
    latex2html
    tar
    gzip,gunzip
    bzip2
    Also support my modem (and my printer sometime in future)

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    The 40 40 ... are from it's attempt to load from the hard disk or from a boot loader on the master boot record (mbr) of the hard disk.

    Try putting a Linux installation in your CDROM and booting from that.

    I suggest that you get yourself either Redhat (7.3, 8.0, or 9.0) or Mandrake (9.0 or above). You can either download these CDs from their sites or you can buy them from various sites (in the UK try www.yourlinux.com where Redhat is called Blue Square for licensing reasons).

    If you want to get rid of the boot loader and go back to uncle bill's OSs, boot with a DOS diskette and do a FDISK /MBR , which will squirt over the top of the mbr.

    Let us know how you get on

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Jul 2003
    Posts
    5

    bugger me! stuck with display settings

    Thanx for the reply. but i should admit that i had overlooked the loading sequence. It was loading from the floppy drive first. Anyway i did change the setting and manage to load from CD-ROM. To start with i had both Mandrake 8.2 and redhat 7.1. I started with Mandrake, but after a few minutes, my computer produced the blue death screeen so familiar to our Windoze! I could have gone back and try loading from the "text" mode as i did in my earlier Mandrake installation.
    Instead, i wanted to try the Redhat. Even with this, the blue death screen did come up, but it went to the text mode automatically. Thats a good thing of red hat guys to do! Anyway now i decided to try the "expert" mode in the redhat installation. Down the lane i had the choice of selecting "Gnome" ,"KDE" and "games". Being a seasoned adventurist(yeah right!), jus' selected the "games" option. then selected the individual packages. Total installation was jus' 808MB.
    Now is the scary part. After the installation, i was to tell about the display settings. The only thing i knew was the graphics card is SIS6202. The closest option was SIS 620 in the list. My monitor is Digital 14" PCXBV-RM. Didn't have that option. So i selected the closest as PCXBV-PF. Then came the question "how much is the Video Memory?" After much guess work, i decided on 512kB. Then came the option for selecting the resolution. decided on 8bit[800X600] option. On self checking, it turned out to be really BIG fonts and the entire disply was way bigger than my monitor and i would see only a part of screen at a time. After letting off my frustration on my mouse, decided to give it a go again.
    Followed the same procedure, but skipped the display settings. Now i could log in only in the text mode. Jus' like the dos. I don't have a clue about how to bring in my graphics card working from here. I jus' can't be bothered to install from scratch.
    It would be really appreciated if any of you guys could answer my following questions:
    1) How to figure out the video Memory?
    2) How to set my display settings(8bit, 16bit or 24 bit) correctly to see fonts properly?
    3) Could i get this info from my text mode or do i have to open the system? If so where should i be looking?
    btw i found the followin info from the file "iomem" in the path /proce/
    00000000 - 0009FBFF : System RAM
    0009FC00 - 0009FFFF : System RAM
    000A0000 - 000BFFFF : Video RAM
    000C0000 - 000C7FFF : Video ROM
    000F0000 - 000FFFFF : System ROM
    00100000 - 04FFFFFF : System RAM
    00100000 - 04224EA7 : Kernel Code
    00224E08 - 00276BECB : Kernel Data
    F0000000 - F006BECB : PCI device 127a:1024 Rockwell International HCF56K Data/Fax/Voice Modem
    FFFF0000 - FFFFFFFF :Reserved

    I am really sorry for such a long message. It would be great if you guys would help me out or lemme know where could i look for more info of all this display settings jargon

    Thanks very much in advance for your help

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Jun 2003
    Location
    55 (degrees) north 7 west
    Posts
    126
    i got the same thing excetp in 99's the only way i know of is that you have to fix the mbr or boot record by doing it in text mode. but i think you'll have to reinstall the os to get it working cause it did'nt work for me.
    sorry i can't be of more help but i don't know much in the field.
    Thanks v much

    \"Anything bigger than my ego i want it caught and killed\"- Zaphod Beeblebrox

    Multi boot:
    Win xp home, SuSE 8.2 and Slackware 9.1

  6. #5
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    the file for the configuration of X is

    /etc/X11/XF86Config (take note of the case of the letters)

    Have a look at the manual pages for it 'man XF86Config'


    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  7. #6
    Just Joined!
    Join Date
    Jul 2003
    Posts
    5

    Thanx guys...still struggling with HUGE fonts!!!

    Thanks very much for your generous help. I sure will try the "XF86config" tonite. btw yesterday nite, i reinstalled the redhat7.1 again(can't get hold of better version!). Same problem with the graphics. Went to text mode.
    I did manage to figure out my video memory -its 1MB. Its shows as the system is booting(never noticed it before!). After playing around for a while i had stumbled on "prefdm" file in /etc/X11/. When i ran it with "./prefdm" surprisingly the Xwindow login screen came up!!! So i could log in but with the same problem of enormously HUGE fonts! But this is possible only if you log in as root, not as other user! Another discovery was going back to the text mode by pressing <cntrl><alt><F1-F6>. And if i press <cntrl><alt><F7>, it will revert back to graphics mode. Glad to find that out I am here at the uni right now. i sure will try the XF86config tonite.
    In the mean time do you guys have any idea of fitting the desktop to the size of the monitor? Its been really long nights recently. It was "gnuchess" which got me up pretty late. Its so simple n' cool, but still losing to the computer . Anyway i really appreciate you help and will let you know more....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •