Find the answer to your Linux question:
Results 1 to 2 of 2
I can connect to the internet using a hardline via eth1, but am having problems with eth0. eth0 is a "LAN-Express IEEE 802.111 PCI Adapter" and I am using Xandros ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414

    using iwconfig and Xandros Connection Wizard


    I can connect to the internet using a hardline via eth1, but am having problems with eth0.
    eth0 is a "LAN-Express IEEE 802.111 PCI Adapter" and I am using Xandros 3.0.1 OS.
    I tried various iwconfig commands, and have had *some* success with this -- I have managed, twice, to get online using wireless, but I have to start from scratch when I restart.
    The problem is that I need to keep trying random iwconfig commands (iwconfig eth0 key blahblahblah, ifdowneth0;ifupeth0, etc.) to get it working, and most of the time I have no luck at all. On top of that Xandros Connection Wizard cannot see eth0 at all!
    iwconfig outputs the following,
    lo no wireless extensions.

    eth0 IEEE 802.11b ESSID:"xxxxxxxx" Nickname:"(none)"
    Mode:Managed Frequency:2.462 GHz Access Point: XX:XX:XX:XX:XX:XX
    Bit Rate:2 Mb/s Sensitivity:1/3
    Retry min limit:8 RTS thr:off Fragment thr:off
    Encryption key:XXXX-XXXX-XX Security mode:restricted
    Power Management:off
    Link Quality=92/92 Signal level=5/153 Noise level=107/153
    Rx invalid nwid:0 Rx invalid crypt:14 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    eth1 no wireless extensions.

    (I have tried to hide any revealing info!!!)

    Any help towards getting online, and having this work as a startup process, would be greatly appreciated.

    Steve

  2. #2
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    some more info. When I enter ifup, ifdown, the following happens...

    smolloy:/proc/net# ifdown eth0
    smolloy:/proc/net# ifup eth0
    Internet Software Consortium DHCP Client V3.0pl1
    Copyright 1995-2001 Internet Software Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/products/DHCP

    Listening on LPF/eth0/00:02:8a:7a:ea:62
    Sending on LPF/eth0/00:02:8a:7a:ea:62
    Sending on Socket/fallback
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.

    Steve

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •