Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
Hi! I have just installed Fedora Core 3 and I have problems playing DVD. I have looked in many sites for help, but... nothing ! It seems that I don't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5

    I want to watch DVDs!!!


    Hi!

    I have just installed Fedora Core 3 and I have problems playing DVD. I have looked in many sites for help, but... nothing ! It seems that I don't have the dvd device or... I don't know. When I try to watch a DVD with xine, it says that there is no input plugin available to handle dvd:/ and when I look in /dev, there is no dvd file. I tried to create it with MAKEDEV but... I'm a newby!!! Please I need help from professionals!!!

    Thank you!

    jpdumal

  2. #2
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    You need a dvd player like ogle or mplayer.
    Check out http://rpmfind.net or http://rpm.pbone.net and do a search for one of those.
    Hope this helps
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5
    Same think appens with mplayer! Could not open DVD device: /dev/dvd!!!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Odds are that you don't have a symbolic link to the dvd rom. To do this, type:
    Code:
    su
    <root password>
    ln -s <your cdrom device> /dev/dvd
    This will create a symbolic link between your dvdrom and /dev/dvd.

    Hope that helps,
    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Location
    Plant City,FL
    Posts
    55
    Xine plays dvd fine.

    You'll likely need to create that sym link and make sure you have libdvdcss installed as well.

  7. #6
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    i had to do the same thing, i created a symlink in /dev called dvd and pointed it to /dev/hdc, then used mkdir to create the mount point /mnt/dvd then added this line to fstab
    Code:
    /dev/dvd         /mnt/dvd         iso9660     noauto,user,ro   0   0
    after this i installed libdvdcss and ogle, configured ogle to use /dev/dvd as it's default device, that's all there was to it.
    also keep in mind that dvd's do not need to be mounted to be played.

    /var/log/dmesg should reveal the location of the drive you're looking for, as mine does here
    Code:
    hdc&#58; _NEC CD-RW NR-7800A, ATAPI CD/DVD-ROM drive
    once you know it's location, the rest should be simple

  8. #7
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    you will probably also have to dl and install a dvd lib file in order for your players to work. libdvdcss I think its called, linux distros, except for linspire do not ship with it and you have to get it on your own.
    Operating System: GNU Emacs

  9. #8
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5
    Thanks to Krendoshazin!
    I did exactelly the same as you said and it works well!
    I don't know if I was suppose to write something else in fstab (depending on my dvd-rom?) but I can read DVDs! But, there's only one problem to resolve... no sounds!!!
    Any ideas? (codecs?)
    I'll be hapy when I'll be able to watch Rocky on my PC!!!

    Thank you!

    jpdumal

  10. #9
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    it might be a simple case of having to activate your sound, all you should need to do is run alsaconf, then alsamixer, make sure all main volumes are at max and unmuted, also pcm needs to be put at max and unmuted.
    once you've set up the mixer properly, "alsactl store" will save the settings to be reused next boot time, btw all this needs to be done as root.

    if this doesn't work, downgrading alsa might work, i've found ogle doesn't like alsa 1.0.8 but does like 1.0.6, i found this out when i upgraded alsa, a downgrade back to 1.0.6 sorted it out

  11. #10
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5
    Well I have to be honest... I don't understand, I have just install FC3 and it's the first time I have to use Linux, I was curious so I format (Windows = scrap ). Yes, I found alsa.conf but I don't know how to run it and if I open it with a text editor... waaa !!! what's that? Another thing, when I try to open the volume controle in the panel it says: " Sorry, no mixer elements and/or devices found"

    Solutions?

    Thanks to you again!

    jpdumal

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •