Find the answer to your Linux question:
Results 1 to 8 of 8
This is a rather weird problem, which has been on my linux server for 1,5 years now. This is how it occurs: Every time I boot the server with 'shutdown ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    9

    Problem with booting & LILO


    This is a rather weird problem, which has been on my linux server for 1,5 years now.

    This is how it occurs:
    Every time I boot the server with 'shutdown -r now' the server kills every process nicely, boots the machine and then stalls on the LILO load.
    Yesterday I ran in the new 2.6.11.8 kernel (and newest LILO, of course) and booted up. The output on screen was like this:
    "L 99 99 99 99 99 99 99 ..." (and 99's kept going till they filled up half of the screen.)
    I ctrl-alt-del-booted the machine and up it went. LILO loaded itself smoothly and my box went up as well.
    Previously with kernel 2.4.18 (and older LILO, 22.2 maybe?) the output was only "LI". And every time the problem could be solved by pressing ctrl-alt-del or reset after LILO hang up.

    I know that there are troubleshooters which explain the meanings of letters L, I, L and O but I just don't understand why the problem comes up only after booting the server. If I cold-start it, the server starts Linux without any problems.

    Any ideas?

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    9
    Anyone?

  3. #3
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Belgrade, S&M
    Posts
    177
    Did you reconfigure lilo after upgrading the kernel ? Did you reinstall lilo ?

  4. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    9
    I ran only /sbin/lilo after adding the new kernel into lilo.conf.
    Should I even re-install it, or what do you mean?

  5. #5
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    It would be helpful to note that users with older hardware, who encounter the L 99 99 99 99 ... error, that adding "linear" in lilo.conf may solve the problem. (It did for me!)
    http://www.wlug.org.nz/LiloErrorCodes

  6. #6
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Belgrade, S&M
    Posts
    177
    I meant reinstalling it in the boot sector ie. running /sbin/lilo. Well if you modified lilo.conf and installed it to the MBR again, then something is probably wrong in the lilio.conf file.
    I also had 99 999 99 99 9 on my screen when I moved linux to another partition but didn't run sbin/lilo.

  7. #7
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    I had that problem a while back...

    Make sure that LILO is installed on the same HD as your /boot directory.

    Also, go to the kernel and run "make install". If I remember correctly, that's what fixed it for me.

  8. #8
    Just Joined!
    Join Date
    May 2005
    Posts
    9
    after running /sbin/lilo...
    Fatal: May specify only one of GEOMETRIC, LINEAR or LBA32
    I don't know if I have "that" old hardware, but I'll give the "linear" instead of "lba32" a try.
    My server is almost the Harley Davidson of all PCs having Celeron 300MHz, Intel SE-440BX2 motherboard, 128MB of PC-100 Samsung memory, 10GB Samsung SpinPoint HD etc.

    EDIT: For a second thought I think I'll keep the lba32 setting since my Samsung has 1240 cylinders and lba32-option seems to be for harddrives having more than 1024 cylinders. Without lba32 the whole HD wouldn't be accessible, if I understood correctly.
    EDIT2: Notice that the problem occurs only half of the time! (At rebooting only.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •