Find the answer to your Linux question:
Results 1 to 8 of 8
Hello out there! Linux newbie here. I am trying to figure out how to configure my /etc/fstab file so that automatically upon boot up, I can access files that I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    8

    Accessing Windows XP from Linux?


    Hello out there!

    Linux newbie here.

    I am trying to figure out how to configure my /etc/fstab file so that automatically upon boot up, I can access files that I have stored in the Windows partition from Linux.

    I have Red Hat Linux running on a Dell machine that is partitioned with Windows XP.

    In my /etc/fstab file I tried the following (after trying to figure out multiple posts in this forum):
    /dev/hda1 /mnt/c ntfs defaults, users, owner,ro,unmask=000 0 0

    Question #1: What do I need to fix/alter?
    Question #2: Once I get this to work, when I open up my /mnt/c folder, where will I be looking in the WinXP partition?

    I know that it is supposed to be the C: drive but where in particular in the C: drive? I am asking because I want to know where to stick things so that when I open /mnt/c in Linux, I can find what I want to find.

    Thanks for any help that anyone can provide!
    ---Nick

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Well, assuming that /dev/hda1 is the Windows partition, it will open you into the C drive. Right there. As in C:\. :P.

    And I fail to see what the problem is here. Are you getting an error message? Or did you simply forget to mount?

    Code:
    mount /mnt/c
    If you get an error message, let us know.

    EDIT:

    Looking at it again, I think that "unmask=000" is supposed to be "umask=0000". Note "umask", not "unmask". Also, remove "owner" from it.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    8
    Thanks for the help!

    I fixed what you mentioned. When I rebooted, it failed to mount and I saw the error message:
    "fs type ntfs not supported by kernel"

    Do I need to have vfat instead of ntfs? I have WinXP.

    Thank you!
    ---Nick

    EDIT:
    here is my fdisk -l ouput:
    Disk /dev/hda: 40.0 GB, 40000000000 bytes
    255 heads, 63 sectors/track, 4863 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 1 4 32098+ de Dell Utility
    /dev/hda2 * 5 1533 12281692+ 7 HPFS/NTFS
    /dev/hda3 1534 4854 26675932+ f Win95 Ext'd (LBA)
    /dev/hda5 1534 1660 1020096 83 Linux
    /dev/hda6 1661 3190 12289693+ 83 Linux
    /dev/hda7 3191 4465 10241406 83 Linux
    /dev/hda8 4466 4592 1020096 82 Linux swap
    /dev/hda9 4593 4719 1020096 83 Linux
    /dev/hda10 4720 4846 1020096 83 Linux

    I tried changing the code to /dev/hda2 to see if that would help but I still got the same error message about 'ntfs not supported by kernel'
    thanks.
    ---Nick

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Acrually the command will be
    Code:
    mount /dev/hda1  /mnt/c
    As root

    As for finding the folder you want. You need to know where it is in Windows.
    If it is a file you are trying to edit. Look ether in "Documents an Settings" or or "Home folde" It will be your username in Windows.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  6. #5
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Nope. If you have the line in fstab, you can either mount the device or the folder, but you don't need both.

    And according to the fdisk output, you're actually gonna want:

    Code:
    /dev/hda2 /mnt/c ntfs defaults, users,ro,umask=0000 0 0
    Now then, my guess is that you've disabled NTFS support in your kernel. Are you familiar with configuring your own kernel?

    If so, open menuconfig and go to:

    File Systems
    DOS/FAT/NT Filesystems
    Select "MSDOS fs Support" and "NTFS file system support"

    Recompile and you're good to go. If you need a more step-by-step walkthrough, let me know.

  7. #6
    Just Joined!
    Join Date
    May 2005
    Posts
    8
    Now then, my guess is that you've disabled NTFS support in your kernel. Are you familiar with configuring your own kernel?

    If so, open menuconfig and go to:

    File Systems
    DOS/FAT/NT Filesystems
    Select "MSDOS fs Support" and "NTFS file system support"

    Recompile and you're good to go. If you need a more step-by-step walkthrough, let me know.

    ----------------------
    yes, I do need a bit more of a step-though.
    If it helps, when I entered "uname -a" I have:
    Linux DHWFXX41 2.4.21-27.0.4.EL #1 Sat Apr 16 19:00:33 EDT 2005 i686 i686 i386 GNU/Linux
    but I have RedHat which it seems doesn't support mounting ntfs? I am confused.

  8. #7
    Just Joined! JoeB's Avatar
    Join Date
    Nov 2004
    Location
    Elburn, Illinois
    Posts
    83
    Fedora doesn't directly support NTFS due to legal issues with Micro$oft (imagine that!)

    You can pull in an .rpm to enable it on your kernel

    http://linux-ntfs.sourceforge.net/

    The step by step instructions are pretty clear

  9. #8
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    That is how I do it on all of my distros. It works on all of them except Fedora,(I just found that out)

    I knew there was a reason not to like FC all that much.
    Maybe it is time to put something else in that partition.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •